summaryrefslogtreecommitdiff
path: root/dev-db/4store
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/4store
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/4store')
-rw-r--r--dev-db/4store/4store-1.1.5.ebuild63
-rw-r--r--dev-db/4store/Manifest1
-rw-r--r--dev-db/4store/metadata.xml8
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-db/4store/4store-1.1.5.ebuild b/dev-db/4store/4store-1.1.5.ebuild
new file mode 100644
index 00000000000..51f47be8b99
--- /dev/null
+++ b/dev-db/4store/4store-1.1.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils user
+
+DESCRIPTION="4store is an efficient, scalable and stable RDF database"
+HOMEPAGE="http://4store.org/"
+# http://4store.org/download/4store-v1.0.4.tar.gz
+MY_P="${PN}-v${PV}"
+SRC_URI="http://4store.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# < http://4store.org/trac/wiki/Dependencies
+DEPEND="media-libs/raptor
+ >=dev-libs/rasqal-0.9.18
+ dev-libs/libxml2
+ dev-libs/libpcre
+ sys-libs/readline
+ sys-libs/ncurses
+ dev-libs/expat
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup fourstore
+ enewuser fourstore -1 -1 /var/lib/4store fourstore
+}
+
+src_install() {
+
+ # patch the Makefiles to use /usr/ instead of /usr/local/
+ find . -name "Makefile" -execdir sed -e "s#/usr/local/#/usr/#" -i {} \;
+
+ MAKEOPTS="-j1" emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodir /var/log/4store
+ fowners fourstore:fourstore \
+ /var/lib/4store \
+ /var/log/4store
+
+ # fix 1777
+ fperms 755 /var/lib/4store
+
+ # fix 755
+ fperms 644 \
+ /usr/share/man/man1/4s-query.1 \
+ /usr/share/man/man1/4s-backend-setup.1 \
+ /usr/share/man/man1/4s-import.1 \
+ /usr/share/man/man1/4s-cluster-info.1 \
+ /usr/share/man/man1/4s-cluster-start.1 \
+ /usr/share/man/man1/4s-cluster-create.1 \
+ /usr/share/man/man1/4s-cluster-stop.1 \
+ /usr/share/man/man1/4s-cluster-destroy.1
+}
diff --git a/dev-db/4store/Manifest b/dev-db/4store/Manifest
new file mode 100644
index 00000000000..dea2c6ddc3d
--- /dev/null
+++ b/dev-db/4store/Manifest
@@ -0,0 +1 @@
+DIST 4store-v1.1.5.tar.gz 5610204 SHA256 2bdd6fb804288802187c5779e365eea2b3ddebce419b3da0609be38edc9e8c5b SHA512 42a7431c7853e1b06a76ed15c205eebd7b334516c14e7dcfeddb2f9249f30f879f8256a1b454be71f79e71205b3efa95efab726fd88b4d455bb0fc4a8092bcf4 WHIRLPOOL 55fd3f725386847c598c80945a01234fb7f3c8ced56f1004f3679d99e7fdf12cb8f92c4f865891491ac0dc66d5194379cbe2022f25bef9134bc041c5f5dd2d92
diff --git a/dev-db/4store/metadata.xml b/dev-db/4store/metadata.xml
new file mode 100644
index 00000000000..24cbb90cf0c
--- /dev/null
+++ b/dev-db/4store/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>