summaryrefslogtreecommitdiff
path: root/dev-db/postgis
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-01-17 07:07:19 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-01-17 07:07:19 -0500
commit3ef20f89a6e5e7d09c77d3a89a9275d24ce60fed (patch)
tree915b1ce45e22d82d95d55f3f3a91c7aa7d562c61 /dev-db/postgis
parent8f38557fc764e1bdef6bf43664c141300beb1f1c (diff)
downloadgentoo-3ef20f89a6e5e7d09c77d3a89a9275d24ce60fed.tar.gz
gentoo-3ef20f89a6e5e7d09c77d3a89a9275d24ce60fed.tar.xz
dev-db/postgis: Bump to 2.4.3
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-db/postgis')
-rw-r--r--dev-db/postgis/Manifest1
-rw-r--r--dev-db/postgis/postgis-2.4.3.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/dev-db/postgis/Manifest b/dev-db/postgis/Manifest
index a1dfb601ce1..0c6de877d40 100644
--- a/dev-db/postgis/Manifest
+++ b/dev-db/postgis/Manifest
@@ -1 +1,2 @@
DIST postgis-2.4.2.tar.gz 12470881 BLAKE2B 116bb5d1c8f6066d537cac950254923a681babac456d155139dbdd2853b80499f4f9445dad985b94bffffd1d1285a6c78fee0fccb24e301d18147f3cd9230416 SHA512 e268572d5cd009754ef05f5d2eedcac7e362fa47199459c637cd4d9050d2b648d4b2b3746cde0dce5a42be2606a432b64dc905f193e12cf0869e3dd6f820b425
+DIST postgis-2.4.3.tar.gz 12601055 BLAKE2B 662b2afe145bc23c77ebda7306d07a20e39c1a598316cee58e1591e65ce1b2d2a3f727f5463ba144711faa55f7c11e4a038b6ad2a76cab760b4fdd43647f09c3 SHA512 95b2c925cb10943e7136aa3b7b08a9ad3d6ff59a3994c653bba52e4c65193d519daa49684b924f68945dd596187aa17e0c713bf0b9e29f8c5973346b279dba1b
diff --git a/dev-db/postgis/postgis-2.4.3.ebuild b/dev-db/postgis/postgis-2.4.3.ebuild
new file mode 100644
index 00000000000..205ce7a381c
--- /dev/null
+++ b/dev-db/postgis/postgis-2.4.3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+POSTGRES_COMPAT=( 9.{2..6} 10 )
+POSTGRES_USEDEP="server"
+
+inherit autotools eutils postgres-multi versionator
+
+MY_PV=$(replace_version_separator 3 '')
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="http://postgis.net"
+SRC_URI="http://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="address-standardizer doc gtk static-libs mapbox test topology"
+
+RDEPEND="
+ ${POSTGRES_DEP}
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ >=sci-libs/geos-3.5.0
+ >=sci-libs/proj-4.6.0
+ >=sci-libs/gdal-1.10.0
+ address-standardizer? ( dev-libs/libpcre )
+ gtk? ( x11-libs/gtk+:2 )
+ mapbox? ( dev-libs/protobuf )
+"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/libxslt
+ || (
+ media-gfx/imagemagick[png]
+ media-gfx/graphicsmagick[imagemagick,png]
+ )
+ )
+ virtual/pkgconfig
+ test? ( dev-util/cunit )
+"
+
+PGIS="$(get_version_component_range 1-2)"
+
+REQUIRED_USE="test? ( doc ) ${POSTGRES_REQ_USE}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+MAKEOPTS+=' -j1'
+
+# These modules are built using the same *FLAGS that were used to build
+# dev-db/postgresql. The right thing to do is to ignore the current
+# *FLAGS settings.
+QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.2.0-arflags.patch" \
+ "${FILESDIR}/postgis-2.4.2-jsonc_0.13.patch"
+
+ local AT_M4DIR="macros"
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ local myargs=""
+
+ use gtk && myargs+=" --with-gui"
+
+ use address-standardizer || myargs+=" --without-address-standardizer"
+ use mapbox || myargs+=" --without-protobuf"
+ use topology || myargs+=" --without-topology"
+
+ postgres-multi_foreach econf ${myargs}
+}
+
+src_compile() {
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C topology
+
+ if use doc ; then
+ postgres-multi_foreach emake comments
+ postgres-multi_foreach emake cheatsheets
+ postgres-multi_forbest emake -C doc html
+ fi
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+ postgres-multi_foreach emake -C topology DESTDIR="${D}" install
+ postgres-multi_forbest dobin ./utils/postgis_restore.pl
+
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+
+ if use doc ; then
+ postgres-multi_foreach emake DESTDIR="${D}" comments-install
+
+ docinto html
+ postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
+
+ docinto html/images
+ postgres-multi_forbest dodoc doc/html/images/*
+ fi
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
+
+pkg_postinst() {
+ ebegin "Refreshing PostgreSQL symlinks"
+ postgresql-config update
+ eend $?
+
+ elog "To finish installing PostGIS, follow the directions detailed at:"
+ elog "http://postgis.net/docs/manual-${PGIS}/postgis_installation.html#create_new_db_extensions"
+}