summaryrefslogtreecommitdiff
path: root/dev-db/recutils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/recutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/recutils')
-rw-r--r--dev-db/recutils/Manifest2
-rw-r--r--dev-db/recutils/files/50recutils-gentoo.el6
-rw-r--r--dev-db/recutils/files/recutils-1.5-automagic.patch57
-rw-r--r--dev-db/recutils/files/recutils-1.5-glibc-2.16.patch29
-rw-r--r--dev-db/recutils/files/recutils-1.7-automagic.patch130
-rw-r--r--dev-db/recutils/metadata.xml13
-rw-r--r--dev-db/recutils/recutils-1.5.ebuild82
-rw-r--r--dev-db/recutils/recutils-1.7.ebuild88
8 files changed, 407 insertions, 0 deletions
diff --git a/dev-db/recutils/Manifest b/dev-db/recutils/Manifest
new file mode 100644
index 00000000000..2aabf289982
--- /dev/null
+++ b/dev-db/recutils/Manifest
@@ -0,0 +1,2 @@
+DIST recutils-1.5.tar.gz 1811121 SHA256 7ed67e74468084f52ad9341e4b11c44e5fd9d5325b93b7eb2cb230c839ff5dec SHA512 6c6091618474b5e54948370ef26db3cb446b0d8719d443fa1dbbdee75f046d536ab61ce803a9443f2e31ab7e46774aaf73c3d4fe2bf9da90a2c508dbbcc611be WHIRLPOOL 25363ec7a03990d0114eb0f1cc161d1685ec7a3e4627b927ef8d0439a5e9998f3836915da12107ddb5bc759bca4b630dea25fa657b89b196c361a1156a3daef8
+DIST recutils-1.7.tar.gz 2252648 SHA256 233dc6dedb1916b887de293454da7e36a74bed9ebea364f7e97e74920051bc31 SHA512 80f6996f2bc02986695223db597cff75aae2bd47b88e81b0dfe44c33f79fc3320108e2715b1af086b167ff1124fe94deeec4e337b1ede99807d381927327bd68 WHIRLPOOL 5263e2a7ffec7681b00dccd0d6302a04e81f4c876ef2ebdd32bf3526cc010ae407b9267a7b9444bd21e552117a3b9b6d326f6782f1470c14125cade430c7f98f
diff --git a/dev-db/recutils/files/50recutils-gentoo.el b/dev-db/recutils/files/50recutils-gentoo.el
new file mode 100644
index 00000000000..1b16da6bbcd
--- /dev/null
+++ b/dev-db/recutils/files/50recutils-gentoo.el
@@ -0,0 +1,6 @@
+
+;; site-init for dev-db/recutils
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'rec-mode "rec-mode" "A mode for viewing/editing rec files." t)
+(add-to-list 'auto-mode-alist '("\\.rec$" . rec-mode))
diff --git a/dev-db/recutils/files/recutils-1.5-automagic.patch b/dev-db/recutils/files/recutils-1.5-automagic.patch
new file mode 100644
index 00000000000..5b928093ce5
--- /dev/null
+++ b/dev-db/recutils/files/recutils-1.5-automagic.patch
@@ -0,0 +1,57 @@
+--- recutils-1.5/configure.ac.orig
++++ recutils-1.5/configure.ac
+@@ -85,17 +85,35 @@
+ fi
+ AC_SUBST([CHECKLIBS])
+
++AC_ARG_ENABLE([curl],
++ AS_HELP_STRING([--enable-curl],
++ [Enable support for remote descriptors using libcurl (default is YES)]),
++ [curl_enabled=$enableval], [curl_enabled=yes])
++
+ have_curl=no
+-AC_CHECK_LIB([curl],[curl_global_init],[have_curl=yes],)
+-if test "x$have_curl" = "xyes"; then
+- CURLLIBS=-lcurl
++if test "x$curl_enabled" = "xyes"; then
++ AC_CHECK_LIB([curl],[curl_global_init],[have_curl=yes],)
++ if test "x$have_curl" = "xyes"; then
++ CURLLIBS=-lcurl
++ else
++ AC_MSG_ERROR([curl support enabled but libcurl not found])
++ fi
+ fi
+ AC_SUBST([CURLLIBS])
+
++AC_ARG_ENABLE([mdb],
++ AS_HELP_STRING([--enable-mdb],
++ [Build the mdb2rec utility (default is YES)]),
++ [mdb_enabled=$enableval], [mdb_enabled=yes])
++
+ have_mdb=no
+-AC_CHECK_LIB([mdb],[mdb_init],[have_mdb=yes],)
+-if test "x$have_mdb" = "xyes"; then
+- MDBLIBS=-lmdb
++if test "x$mdb_enabled" = "xyes"; then
++ AC_CHECK_LIB([mdb],[mdb_init],[have_mdb=yes],)
++ if test "x$have_mdb" = "xyes"; then
++ MDBLIBS=-lmdb
++ else
++ AC_MSG_ERROR([mdb support enabled but libmdb not found])
++ fi
+ fi
+ AC_SUBST([MDBLIBS])
+
+@@ -119,8 +137,10 @@
+ AC_SUBST([crypt_support])
+
+ have_glib=no
+-PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.0.0],
+- [have_glib=yes], [have_glib=no])
++if test "x$mdb_enabled" = "xyes"; then
++ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.0.0],
++ [have_glib=yes], [have_glib=no])
++fi
+
+ AM_CONDITIONAL([COMPILE_MDB2REC],
+ [test "x$have_glib" = "xyes" && test "x$have_mdb" = "xyes"])
diff --git a/dev-db/recutils/files/recutils-1.5-glibc-2.16.patch b/dev-db/recutils/files/recutils-1.5-glibc-2.16.patch
new file mode 100644
index 00000000000..8b4997f099d
--- /dev/null
+++ b/dev-db/recutils/files/recutils-1.5-glibc-2.16.patch
@@ -0,0 +1,29 @@
+--- recutils-1.5/lib/stdio.in.h
++++ recutils-1.5/lib/stdio.in.h
+@@ -699,22 +699,11 @@
+ # endif
+ #endif
+
+-#if @GNULIB_GETS@
+-# if @REPLACE_STDIO_READ_FUNCS@ && @GNULIB_STDIO_H_NONBLOCKING@
+-# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-# undef gets
+-# define gets rpl_gets
+-# endif
+-_GL_FUNCDECL_RPL (gets, char *, (char *s) _GL_ARG_NONNULL ((1)));
+-_GL_CXXALIAS_RPL (gets, char *, (char *s));
+-# else
+-_GL_CXXALIAS_SYS (gets, char *, (char *s));
+-# undef gets
+-# endif
+-_GL_CXXALIASWARN (gets);
+ /* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning. Assume it is
+- always declared, since it is required by C89. */
++ so any use of gets warrants an unconditional warning; besides, C11
++ removed it. */
++#undef gets
++#if HAVE_RAW_DECL_GETS
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
+
diff --git a/dev-db/recutils/files/recutils-1.7-automagic.patch b/dev-db/recutils/files/recutils-1.7-automagic.patch
new file mode 100644
index 00000000000..e5d33bf8749
--- /dev/null
+++ b/dev-db/recutils/files/recutils-1.7-automagic.patch
@@ -0,0 +1,130 @@
+--- recutils-1.7/configure.ac
++++ recutils-1.7/configure.ac
+@@ -85,17 +85,32 @@
+ fi
+ AC_SUBST([CHECKLIBS])
+
++AC_ARG_ENABLE([curl],
++ AS_HELP_STRING([--enable-curl],
++ [Enable support for remote descriptors using libcurl (default is YES)]),
++ [curl_enabled=$enableval], [curl_enabled=yes])
+ have_curl=no
+-AC_CHECK_LIB([curl],[curl_global_init],[have_curl=yes],)
+-if test "x$have_curl" = "xyes"; then
+- CURLLIBS=-lcurl
++if test "x$curl_enabled" = "xyes"; then
++ AC_CHECK_LIB([curl],[curl_global_init],[have_curl=yes],)
++ if test "x$have_curl" = "xyes"; then
++ CURLLIBS=-lcurl
++ else
++ AC_MSG_ERROR([curl support enabled but libcurl not found])
++ fi
+ fi
+ AC_SUBST([CURLLIBS])
+
++AC_ARG_ENABLE([uuid],
++ AS_HELP_STRING([--enable-uuid],
++ [Compile recutils with support for uuid types (default is YES)]),
++ [uuid_enabled=$enableval], [uuid_enabled=yes])
++
+ have_uuid=no
+-AC_CHECK_LIB([uuid],[uuid_generate],[have_uuid=yes],)
+-if test "x$have_uuid" = "xyes"; then
+- UUIDLIBS=-luuid
++if test "x$uuid_enabled" = "xyes"; then
++ AC_CHECK_LIB([uuid],[uuid_generate],[have_uuid=yes],)
++ if test "x$have_uuid" = "xyes"; then
++ UUIDLIBS=-luuid
++ fi
+ fi
+ AC_SUBST([UUIDLIBS])
+ AC_SUBST([have_uuid])
+@@ -119,32 +134,42 @@
+ AM_CONDITIONAL([CRYPT], [test "x$crypt_support" = "xyes"])
+ AC_SUBST([crypt_support])
+
+-have_glib=no
+-PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.0.0],
+- [have_glib=yes], [have_glib=no])
+-
++AC_ARG_ENABLE([mdb],
++ AS_HELP_STRING([--enable-mdb],
++ [Build the mdb2rec utility (default is YES)]),
++ [mdb_enabled=$enableval], [mdb_enabled=yes])
+ have_mdb=no
+-AC_CHECK_LIB([mdb],[mdb_init],[have_mdb=yes],)
+-if test "x$have_mdb" = "xyes"; then
+- MDBLIBS=-lmdb
+-
+- OLD_CFLAGS=$CFLAGS
+- CFLAGS="$CFLAGS $pkg_cv_GLIB_CFLAGS"
+- mdb_uses_sdatetime=no
+- AC_CHECK_DECL([MDB_SDATETIME],[mdb_uses_sdatetime=yes],,[#include <glib.h>
++if test "x$mdb_enabled" = "xyes"; then
++ AC_CHECK_LIB([mdb],[mdb_init],[have_mdb=yes],)
++ if test "x$have_mdb" = "xyes"; then
++ MDBLIBS=-lmdb
++
++ OLD_CFLAGS=$CFLAGS
++ CFLAGS="$CFLAGS $pkg_cv_GLIB_CFLAGS"
++ mdb_uses_sdatetime=no
++ AC_CHECK_DECL([MDB_SDATETIME],[mdb_uses_sdatetime=yes],,[#include <glib.h>
+ #include <mdbtools.h>])
+- CFLAGS=$OLD_CFLAGS
++ CFLAGS=$OLD_CFLAGS
+
+- if test "x$mdb_uses_sdatetime" = "xyes"; then
+- MDB_DATETIME="MDB_SDATETIME"
++ if test "x$mdb_uses_sdatetime" = "xyes"; then
++ MDB_DATETIME="MDB_SDATETIME"
++ else
++ MDB_DATETIME="MDB_DATETIME"
++ fi
+ else
+- MDB_DATETIME="MDB_DATETIME"
++ AC_MSG_ERROR([mdb support enabled but libmdb not found])
+ fi
+
+ AC_SUBST([MDB_DATETIME])
+ fi
+ AC_SUBST([MDBLIBS])
+
++have_glib=no
++if test "x$mdb_enabled" = "xyes"; then
++ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.0.0],
++ [have_glib=yes], [have_glib=no])
++fi
++
+ AM_CONDITIONAL([COMPILE_MDB2REC],
+ [test "x$have_glib" = "xyes" && test "x$have_mdb" = "xyes"])
+ AM_CONDITIONAL([REMOTE_DESCRIPTORS], [test "x$have_curl" = "xyes"])
+@@ -233,29 +258,6 @@
+
+ dnl Report warnings
+
+-if test "x$have_check" = "xno"; then
+- echo "warning: libcheck was not found in the system."
+- echo "warning: unit tests wont be compiled and executed upon make check."
+-fi
+-
+-if test "x$have_mdb" = "xno"; then
+- echo "warning: libmdb was not found in the system."
+- echo "warning: the mdb2rec utility won't get built."
+-fi
+-
+-if test "x$have_glib" = "xno"; then
+- echo "warning: glib was not found in the system."
+- echo "warning: the mdb2rec utility won't get built."
+-fi
+-
+-if test "x$crypt_support" = "xno"; then
+- echo "warning: building recutils without encryption support."
+-fi
+-
+-if test "x$have_uuid" = "xno"; then
+- echo "warning: building recutils without support for uuid types."
+-fi
+-
+ if test "x$bash_headers_available" = "xno" || test "x$bash_builtins_enabled" = "xno"; then
+ echo "warning: not building the recutils bash builtins."
+ fi
diff --git a/dev-db/recutils/metadata.xml b/dev-db/recutils/metadata.xml
new file mode 100644
index 00000000000..8012f655304
--- /dev/null
+++ b/dev-db/recutils/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="curl">Enable support for remote descriptors using libcurl</flag>
+ <flag name="mdb">Build the mdb2rec utility</flag>
+ <flag name="uuid">Enable support for uuid types</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-db/recutils/recutils-1.5.ebuild b/dev-db/recutils/recutils-1.5.ebuild
new file mode 100644
index 00000000000..5017f95c861
--- /dev/null
+++ b/dev-db/recutils/recutils-1.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils elisp-common
+
+DESCRIPTION="Tools and libraries to access human-editable, plain text databases"
+HOMEPAGE="http://www.gnu.org/software/recutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt curl emacs mdb nls static-libs"
+
+RDEPEND="sys-libs/readline
+ crypt? (
+ dev-libs/libgcrypt:0
+ dev-libs/libgpg-error
+ )
+ curl? ( net-misc/curl )
+ emacs? (
+ app-emacs/org-mode
+ virtual/emacs
+ )
+ mdb? (
+ app-office/mdbtools
+ dev-libs/glib:2
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-automagic.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.16.patch
+
+ # Don't unconditionally install emacs files
+ sed -i -e "/^dist_lisp_DATA/d" etc/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable crypt encryption) \
+ $(use_enable curl) \
+ $(use_enable mdb) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile etc/*.el || die
+ fi
+}
+
+src_install() {
+ default
+ use static-libs || find "${D}" -name '*.la' -delete
+
+ if use emacs ; then
+ elisp-install ${PN} etc/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-db/recutils/recutils-1.7.ebuild b/dev-db/recutils/recutils-1.7.ebuild
new file mode 100644
index 00000000000..9021fb5f228
--- /dev/null
+++ b/dev-db/recutils/recutils-1.7.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils elisp-common
+
+DESCRIPTION="Tools and libraries to access human-editable, plain text databases"
+HOMEPAGE="http://www.gnu.org/software/recutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt curl emacs mdb nls static-libs +uuid"
+
+RDEPEND="sys-libs/readline
+ crypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ curl? ( net-misc/curl )
+ emacs? (
+ app-emacs/org-mode
+ virtual/emacs
+ )
+ mdb? (
+ app-office/mdbtools
+ dev-libs/glib:2
+ )
+ nls? ( virtual/libintl )
+ uuid? ( sys-apps/util-linux )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-automagic.patch
+
+ # don't unconditionally install emacs files
+ sed -i "/^dist_lisp_DATA/d" etc/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable crypt encryption) \
+ $(use_enable curl) \
+ $(use_enable mdb) \
+ $(use_enable nls) \
+ $(use_enable uuid) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile etc/*.el || die
+ fi
+}
+
+src_test() {
+ # tests have parallel issues
+ emake -j1 check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if use emacs ; then
+ elisp-install ${PN} etc/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}