summaryrefslogtreecommitdiff
path: root/dev-db/sqliteman
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2017-04-16 20:43:09 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-17 00:27:21 +0200
commitfdfa8e286694ce2f4380ac8313a112174bdb35a8 (patch)
tree85130c275078a099f84efea3d84e372a85535954 /dev-db/sqliteman
parentf85bc9546fba4f27bc9bacfdfa3bda88a4a19f10 (diff)
downloadgentoo-fdfa8e286694ce2f4380ac8313a112174bdb35a8.tar.gz
gentoo-fdfa8e286694ce2f4380ac8313a112174bdb35a8.tar.xz
dev-db/sqliteman: Fix building with qscintilla-2.10
Closes: https://github.com/gentoo/gentoo/pull/4431
Diffstat (limited to 'dev-db/sqliteman')
-rw-r--r--dev-db/sqliteman/files/sqliteman-1.2.2-qscintilla-2.10.patch13
-rw-r--r--dev-db/sqliteman/sqliteman-1.2.2-r3.ebuild34
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-db/sqliteman/files/sqliteman-1.2.2-qscintilla-2.10.patch b/dev-db/sqliteman/files/sqliteman-1.2.2-qscintilla-2.10.patch
new file mode 100644
index 00000000000..c197ad34211
--- /dev/null
+++ b/dev-db/sqliteman/files/sqliteman-1.2.2-qscintilla-2.10.patch
@@ -0,0 +1,13 @@
+diff --git a/cmake/modules/FindQScintilla.cmake b/cmake/modules/FindQScintilla.cmake
+index c4592d0..7700ec4 100644
+--- a/cmake/modules/FindQScintilla.cmake
++++ b/cmake/modules/FindQScintilla.cmake
+@@ -21,7 +21,7 @@ IF(QT4_FOUND)
+ "${QT_INCLUDE_DIR}/Qsci" /usr/include /usr/include/Qsci
+ )
+
+- SET(QSCINTILLA_NAMES ${QSCINTILLA_NAMES} qscintilla2 libqscintilla2)
++ SET(QSCINTILLA_NAMES ${QSCINTILLA_NAMES} qscintilla2 libqscintilla2 qscintilla2_qt4 libqscintilla2_qt4)
+ FIND_LIBRARY(QSCINTILLA_LIBRARY
+ NAMES ${QSCINTILLA_NAMES}
+ PATHS ${QT_LIBRARY_DIR}
diff --git a/dev-db/sqliteman/sqliteman-1.2.2-r3.ebuild b/dev-db/sqliteman/sqliteman-1.2.2-r3.ebuild
new file mode 100644
index 00000000000..6b05f4741a6
--- /dev/null
+++ b/dev-db/sqliteman/sqliteman-1.2.2-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Powerful GUI manager for the Sqlite3 database"
+HOMEPAGE="http://sqliteman.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4[sqlite]
+ x11-libs/qscintilla:=[qt4(-)]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-lpthread.patch"
+ "${FILESDIR}/${P}-qscintilla-2.10.patch"
+)
+
+src_prepare() {
+ # remove bundled lib
+ rm -rf "${S}"/${PN}/qscintilla2 || die
+
+ cmake-utils_src_prepare
+}