summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-08-19 14:59:39 +0200
committerUltrabug <ultrabug@gentoo.org>2016-08-19 14:59:39 +0200
commit18c044e24a836c6d333c99b557bc8a6ee6be810e (patch)
tree2d6cea7f70e48ac1258215482c37d685ec940723 /dev-db
parent5752ffa5c4143b4d060236686b28d569ad5a384d (diff)
downloadgentoo-18c044e24a836c6d333c99b557bc8a6ee6be810e.tar.gz
gentoo-18c044e24a836c6d333c99b557bc8a6ee6be810e.tar.xz
dev-db/mongodb: fix REPLACING_VERSION detection #589458
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mongodb/mongodb-2.6.11.ebuild46
-rw-r--r--dev-db/mongodb/mongodb-2.6.12.ebuild44
-rw-r--r--dev-db/mongodb/mongodb-2.6.8.ebuild46
-rw-r--r--dev-db/mongodb/mongodb-3.0.10.ebuild36
-rw-r--r--dev-db/mongodb/mongodb-3.0.12.ebuild36
-rw-r--r--dev-db/mongodb/mongodb-3.2.8.ebuild36
6 files changed, 134 insertions, 110 deletions
diff --git a/dev-db/mongodb/mongodb-2.6.11.ebuild b/dev-db/mongodb/mongodb-2.6.11.ebuild
index 72addb11db5..3f63202fa45 100644
--- a/dev-db/mongodb/mongodb-2.6.11.ebuild
+++ b/dev-db/mongodb/mongodb-2.6.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -156,25 +156,29 @@ src_test() {
}
pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 2.6 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "${PN} configuration files have changed !"
- ewarn " "
- ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
- ewarn " "
- ewarn "Make sure you also follow the upgrading process :"
- ewarn " http://docs.mongodb.org/master/release-notes/2.6-upgrade/"
- ewarn " "
- if use mms-agent; then
- ewarn "MMS Agent configuration file has been moved to :"
- ewarn " /etc/mms-agent.conf"
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.6 ${v}; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "${PN} configuration files have changed !"
+ ewarn " "
+ ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
+ ewarn " "
+ ewarn "Make sure you also follow the upgrading process :"
+ ewarn " http://docs.mongodb.org/master/release-notes/2.6-upgrade/"
+ ewarn " "
+ if use mms-agent; then
+ ewarn "MMS Agent configuration file has been moved to :"
+ ewarn " /etc/mms-agent.conf"
+ fi
+ break
+ else
+ if use mms-agent; then
+ elog "Edit your MMS Agent configuration file :"
+ elog " /etc/mms-agent.conf"
+ fi
fi
- else
- if use mms-agent; then
- elog "Edit your MMS Agent configuration file :"
- elog " /etc/mms-agent.conf"
- fi
- fi
+ done
}
diff --git a/dev-db/mongodb/mongodb-2.6.12.ebuild b/dev-db/mongodb/mongodb-2.6.12.ebuild
index b206aeccb0f..3f63202fa45 100644
--- a/dev-db/mongodb/mongodb-2.6.12.ebuild
+++ b/dev-db/mongodb/mongodb-2.6.12.ebuild
@@ -156,25 +156,29 @@ src_test() {
}
pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 2.6 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "${PN} configuration files have changed !"
- ewarn " "
- ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
- ewarn " "
- ewarn "Make sure you also follow the upgrading process :"
- ewarn " http://docs.mongodb.org/master/release-notes/2.6-upgrade/"
- ewarn " "
- if use mms-agent; then
- ewarn "MMS Agent configuration file has been moved to :"
- ewarn " /etc/mms-agent.conf"
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.6 ${v}; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "${PN} configuration files have changed !"
+ ewarn " "
+ ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
+ ewarn " "
+ ewarn "Make sure you also follow the upgrading process :"
+ ewarn " http://docs.mongodb.org/master/release-notes/2.6-upgrade/"
+ ewarn " "
+ if use mms-agent; then
+ ewarn "MMS Agent configuration file has been moved to :"
+ ewarn " /etc/mms-agent.conf"
+ fi
+ break
+ else
+ if use mms-agent; then
+ elog "Edit your MMS Agent configuration file :"
+ elog " /etc/mms-agent.conf"
+ fi
fi
- else
- if use mms-agent; then
- elog "Edit your MMS Agent configuration file :"
- elog " /etc/mms-agent.conf"
- fi
- fi
+ done
}
diff --git a/dev-db/mongodb/mongodb-2.6.8.ebuild b/dev-db/mongodb/mongodb-2.6.8.ebuild
index 1fff19c51cd..4059772252d 100644
--- a/dev-db/mongodb/mongodb-2.6.8.ebuild
+++ b/dev-db/mongodb/mongodb-2.6.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -156,25 +156,29 @@ src_test() {
}
pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 2.6 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "${PN} configuration files have changed !"
- ewarn " "
- ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
- ewarn " "
- ewarn "Make sure you also follow the upgrading process :"
- ewarn " http://docs.mongodb.org/master/release-notes/2.6-upgrade/"
- ewarn " "
- if use mms-agent; then
- ewarn "MMS Agent configuration file has been moved to :"
- ewarn " /etc/mms-agent.conf"
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.6 ${v}; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "${PN} configuration files have changed !"
+ ewarn " "
+ ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
+ ewarn " "
+ ewarn "Make sure you also follow the upgrading process :"
+ ewarn " http://docs.mongodb.org/master/release-notes/2.6-upgrade/"
+ ewarn " "
+ if use mms-agent; then
+ ewarn "MMS Agent configuration file has been moved to :"
+ ewarn " /etc/mms-agent.conf"
+ fi
+ break
+ else
+ if use mms-agent; then
+ elog "Edit your MMS Agent configuration file :"
+ elog " /etc/mms-agent.conf"
+ fi
fi
- else
- if use mms-agent; then
- elog "Edit your MMS Agent configuration file :"
- elog " /etc/mms-agent.conf"
- fi
- fi
+ done
}
diff --git a/dev-db/mongodb/mongodb-3.0.10.ebuild b/dev-db/mongodb/mongodb-3.0.10.ebuild
index 4c1614ece5c..437e0b06baa 100644
--- a/dev-db/mongodb/mongodb-3.0.10.ebuild
+++ b/dev-db/mongodb/mongodb-3.0.10.ebuild
@@ -137,20 +137,24 @@ src_test() {
}
pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 3.0 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "${PN} configuration files have changed !"
- ewarn " "
- ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
- ewarn " "
- ewarn "Make sure you also follow the upgrading process :"
- ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
- ewarn " "
- ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
- ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
- ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 3.0 ${v}; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "${PN} configuration files have changed !"
+ ewarn " "
+ ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
+ ewarn " "
+ ewarn "Make sure you also follow the upgrading process :"
+ ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
+ ewarn " "
+ ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
+ ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
+ ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
+ break
+ fi
+ done
}
diff --git a/dev-db/mongodb/mongodb-3.0.12.ebuild b/dev-db/mongodb/mongodb-3.0.12.ebuild
index 4c1614ece5c..437e0b06baa 100644
--- a/dev-db/mongodb/mongodb-3.0.12.ebuild
+++ b/dev-db/mongodb/mongodb-3.0.12.ebuild
@@ -137,20 +137,24 @@ src_test() {
}
pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 3.0 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "${PN} configuration files have changed !"
- ewarn " "
- ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
- ewarn " "
- ewarn "Make sure you also follow the upgrading process :"
- ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
- ewarn " "
- ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
- ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
- ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 3.0 ${v}; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "${PN} configuration files have changed !"
+ ewarn " "
+ ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
+ ewarn " "
+ ewarn "Make sure you also follow the upgrading process :"
+ ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
+ ewarn " "
+ ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
+ ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
+ ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
+ break
+ fi
+ done
}
diff --git a/dev-db/mongodb/mongodb-3.2.8.ebuild b/dev-db/mongodb/mongodb-3.2.8.ebuild
index 1854cf2241f..15b346cad3b 100644
--- a/dev-db/mongodb/mongodb-3.2.8.ebuild
+++ b/dev-db/mongodb/mongodb-3.2.8.ebuild
@@ -160,22 +160,26 @@ src_test() {
}
pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 3.0 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "${PN} configuration files have changed !"
- ewarn " "
- ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
- ewarn " "
- ewarn "Make sure you also follow the upgrading process :"
- ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
- ewarn " "
- ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
- ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
- ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 3.0 ${v}; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "${PN} configuration files have changed !"
+ ewarn " "
+ ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
+ ewarn " "
+ ewarn "Make sure you also follow the upgrading process :"
+ ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
+ ewarn " "
+ ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
+ ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
+ ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
+ break
+ fi
+ done
ewarn "Make sure to read the release notes and follow the upgrade process:"
ewarn " https://docs.mongodb.org/manual/release-notes/3.2/"