summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMax Satula <maksym.satula@gmail.com>2017-07-27 15:46:24 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-30 12:25:25 +0200
commit4206e6636d297eb834f8117d70ae89ac1ea00864 (patch)
treefa5ecb22f872e4dc878434f2d3de3dd806f4a85b /dev-db
parent8999ec597736f140eb473c68f95ca3d7e3faa25c (diff)
downloadgentoo-4206e6636d297eb834f8117d70ae89ac1ea00864.tar.gz
gentoo-4206e6636d297eb834f8117d70ae89ac1ea00864.tar.xz
dev-db/ocp: New package
ocp is a command line tool to download and upload files from/to Oracle Database directories using Oracle SQL Net connection only Package-Manager: Portage-2.3.2, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5225
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/ocp/Manifest1
-rw-r--r--dev-db/ocp/metadata.xml16
-rw-r--r--dev-db/ocp/ocp-0.2.ebuild41
-rw-r--r--dev-db/ocp/ocp-9999.ebuild41
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-db/ocp/Manifest b/dev-db/ocp/Manifest
new file mode 100644
index 00000000000..88420d44ff6
--- /dev/null
+++ b/dev-db/ocp/Manifest
@@ -0,0 +1 @@
+DIST ocp-0.2.tar.gz 144968 SHA256 d6afd26d5342ecb8444a610e21822c926f1af8e3b65ec0d3c0f0bf8a35bde39a SHA512 0ff132a368a615c2a8e8ecb391da138ce9fd52d638de82e5a4d1c9ec3340b117c9c4d8f971ee86724664f93b4073b189407c3c19a0c22c961922145d30221c85 WHIRLPOOL a21b575e668336b62b2fae418faa28bfd80e6f187dbdac2e150a458985ff940289e24fcd556e5fc0f48c6dccce27549772b6594a095d2eff940dd458215a41d1
diff --git a/dev-db/ocp/metadata.xml b/dev-db/ocp/metadata.xml
new file mode 100644
index 00000000000..1d504426439
--- /dev/null
+++ b/dev-db/ocp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>maksym.satula@gmail.com</email>
+ <name>Max Satula</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/maxsatula/ocp/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">A tool for downloading and uploading files from/to Oracle Database directories using Oracle SQL Net connection only</longdescription>
+</pkgmetadata>
diff --git a/dev-db/ocp/ocp-0.2.ebuild b/dev-db/ocp/ocp-0.2.ebuild
new file mode 100644
index 00000000000..3745af1f5a8
--- /dev/null
+++ b/dev-db/ocp/ocp-0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Oracle copy tool"
+HOMEPAGE="https://github.com/maxsatula/ocp"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-db/oracle-instantclient-basic
+ dev-libs/popt
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ append-ldflags $(no-as-needed)
+ default
+}
diff --git a/dev-db/ocp/ocp-9999.ebuild b/dev-db/ocp/ocp-9999.ebuild
new file mode 100644
index 00000000000..3745af1f5a8
--- /dev/null
+++ b/dev-db/ocp/ocp-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Oracle copy tool"
+HOMEPAGE="https://github.com/maxsatula/ocp"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-db/oracle-instantclient-basic
+ dev-libs/popt
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ append-ldflags $(no-as-needed)
+ default
+}