summaryrefslogtreecommitdiff
path: root/dev-dotnet/ikvm-bin
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/ikvm-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/ikvm-bin')
-rw-r--r--dev-dotnet/ikvm-bin/Manifest2
-rw-r--r--dev-dotnet/ikvm-bin/files/ikvm-0.36.0.5.pc.in9
-rw-r--r--dev-dotnet/ikvm-bin/ikvm-bin-0.46.0.2.ebuild51
-rw-r--r--dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild51
-rw-r--r--dev-dotnet/ikvm-bin/metadata.xml5
5 files changed, 118 insertions, 0 deletions
diff --git a/dev-dotnet/ikvm-bin/Manifest b/dev-dotnet/ikvm-bin/Manifest
new file mode 100644
index 00000000000..e8556fb69de
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/Manifest
@@ -0,0 +1,2 @@
+DIST ikvmbin-0.46.0.2.zip 15683101 SHA256 6694698b03910282eae1bbdfccd935f7f90396cad17a657c4734f66fc1e69f13 SHA512 6831c5aa69ec7ec7b60697c436404a79b3985f6732908d6da990132e44a13f6823ce2d69b41f3e742bfac8c9b0bdd002e24b47d2125919d6cbd59e45ddcd37d9 WHIRLPOOL f600b934dcd98ea751f6c2511e1720143cbcd02ffaebf0fb1a2026724212f361125544cd18f30bfb824d14d972b8df64a7ef8089cd7d7372cf706420cf1a8480
+DIST ikvmbin-7.1.4532.2.zip 16391340 SHA256 f28f6ae9bd58bf8ed3f23ab2cb4003676ca8c036e063f3641957386f4aa24572 SHA512 a447473741541e13b6723feef7f474a01670d885ffbfd68269b121cfb39658ca0189f30e055b811f7c72e320b7a28e115b2b858679c43b55b86f00a1429ecdae WHIRLPOOL 0fee6104d1d3f9e9446bd33186bb92801f2d7483db4b3c1ed7bac5dc3274f4062a3f06b007fea21de4cee50c62be0b5c6ed40d525a6e145bc8eb833dd760f6c2
diff --git a/dev-dotnet/ikvm-bin/files/ikvm-0.36.0.5.pc.in b/dev-dotnet/ikvm-bin/files/ikvm-0.36.0.5.pc.in
new file mode 100644
index 00000000000..aaf131f3531
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/files/ikvm-0.36.0.5.pc.in
@@ -0,0 +1,9 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/@LIBDIR@
+
+
+Name: IKVM.NET
+Description: An implementation of Java for Mono and the Microsoft .NET Framework.
+Version: @VERSION@
+Libs: -r:${libdir}/ikvm/IKVM.Runtime.dll -r:${libdir}/ikvm/IKVM.OpenJDK.ClassLibrary.dll -r:${libdir}/ikvm/IKVM.AWT.WinForms.dll
diff --git a/dev-dotnet/ikvm-bin/ikvm-bin-0.46.0.2.ebuild b/dev-dotnet/ikvm-bin/ikvm-bin-0.46.0.2.ebuild
new file mode 100644
index 00000000000..f59ffdf5699
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/ikvm-bin-0.46.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils mono multilib
+
+MY_P=${P/-bin/}
+MY_PN=${PN/-bin/}
+
+DESCRIPTION="Java VM for .NET"
+HOMEPAGE="http://www.ikvm.net/ http://weblog.ikvm.net/"
+SRC_URI="http://www.frijters.net/${MY_PN}bin-${PV}.zip"
+LICENSE="ZLIB GPL-2-with-linking-exception"
+
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.1
+ !dev-dotnet/ikvm
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/$(get_libdir)/${MY_PN}
+ doins bin/*
+
+ for exe in ikvm ikvmc ikvmstub;
+ do
+ make_wrapper ${exe} "mono /usr/$(get_libdir)/${MY_PN}/${exe}.exe" || die
+ done
+
+ dodir /usr/$(get_libdir)/pkgconfig
+ sed -e "s:@VERSION@:${PV}:" \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ "${FILESDIR}"/ikvm-0.36.0.5.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${MY_PN}.pc \
+ || die "sed failed"
+
+ for dll in bin/IKVM*.dll
+ do
+ dllbase=${dll##*/}
+ ebegin "Installing and registering ${dllbase}"
+ gacutil -i bin/${dllbase} -root "${D}"/usr/$(get_libdir) \
+ -gacdir /usr/$(get_libdir) -package IKVM &>/dev/null
+ eend $? || die "Failed installing ${dllbase}"
+ done
+}
diff --git a/dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild b/dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild
new file mode 100644
index 00000000000..16dcaa8d1d6
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils mono multilib
+
+MY_P=${P/-bin/}
+MY_PN=${PN/-bin/}
+
+DESCRIPTION="Java VM for .NET"
+HOMEPAGE="http://www.ikvm.net/ http://weblog.ikvm.net/"
+SRC_URI="http://www.frijters.net/${MY_PN}bin-${PV}.zip"
+LICENSE="ZLIB GPL-2-with-linking-exception"
+
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.1
+ !dev-dotnet/ikvm
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/$(get_libdir)/${MY_PN}
+ doins bin/*
+
+ for exe in ikvm ikvmc ikvmstub;
+ do
+ make_wrapper ${exe} "mono /usr/$(get_libdir)/${MY_PN}/${exe}.exe" || die
+ done
+
+ dodir /usr/$(get_libdir)/pkgconfig
+ sed -e "s:@VERSION@:${PV}:" \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ "${FILESDIR}"/ikvm-0.36.0.5.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${MY_PN}.pc \
+ || die "sed failed"
+
+ for dll in bin/IKVM*.dll
+ do
+ dllbase=${dll##*/}
+ ebegin "Installing and registering ${dllbase}"
+ gacutil -i bin/${dllbase} -root "${D}"/usr/$(get_libdir) \
+ -gacdir /usr/$(get_libdir) -package IKVM &>/dev/null
+ eend $? || die "Failed installing ${dllbase}"
+ done
+}
diff --git a/dev-dotnet/ikvm-bin/metadata.xml b/dev-dotnet/ikvm-bin/metadata.xml
new file mode 100644
index 00000000000..e01adbb307d
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>