summaryrefslogtreecommitdiff
path: root/dev-embedded/arduino
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2017-02-19 21:56:59 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-08-26 00:44:14 +0200
commitfed4b3089dd30d2a64384c414770a46280ba1a54 (patch)
tree9825ac18273e5c0b1959ec752b3e95d641e3dd2b /dev-embedded/arduino
parent690de00d9350894bacc92e6081d00353eee1d8bb (diff)
downloadgentoo-fed4b3089dd30d2a64384c414770a46280ba1a54.tar.gz
gentoo-fed4b3089dd30d2a64384c414770a46280ba1a54.tar.xz
dev-embedded/arduino: update SRC_URI and EAPI 6 bump.
This commit. - changes SRC_URI from googlecode.com to github - updates EAPI from version 4 to 6. Gentoo-Bug: https://bugs.gentoo.org/610036 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5158
Diffstat (limited to 'dev-embedded/arduino')
-rw-r--r--dev-embedded/arduino/Manifest1
-rw-r--r--dev-embedded/arduino/arduino-1.0.5-r2.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-embedded/arduino/Manifest b/dev-embedded/arduino/Manifest
index de225ccf674..a702c2d0f27 100644
--- a/dev-embedded/arduino/Manifest
+++ b/dev-embedded/arduino/Manifest
@@ -1,2 +1,3 @@
DIST arduino-1.0.5-src.tar.gz 40526292 SHA256 2f222c944d317dcae40c2d9a1e8ca8c2092f1fff4e3d1814c609209ffc9afe17 SHA512 0401bf6051a48d343f9e4e822446a846b2c6446c68949efe5daf5f5445114312eecb9c99a4565ab2e2f80831aaa32122ecc21f81c8a97136704482cd0f1f1c00 WHIRLPOOL 9176557007b039dae097dd96fc6a56956117ec879f3689005493bb19f54909e6f502672c92e81cb8bdc24b3a661881ffd696e7179b4dfc4a68af38a8d05cee93
DIST arduino-icons.tar.bz2 58775 SHA256 9086ae27a13cc19e428ed7e6434366752b33a7d066b5620bfdd371709277390e SHA512 b750e79d6117f5df619f2b765dad6e64f0ba4aa3314b0b6e00801577e3ea1f15951ba15efe7a00f5317285a19ac29ac41c78b71342f45cd164c794a42bafcdd9 WHIRLPOOL b53ab3ff2981ca9f6d45311b9f885ca831700a7a49fef4a376cdc489f7cc3a6c39fbb93994b962b6854b0833d7342b951b5c6327422aafce762f92952b7a5876
+DIST arduino-src-1.0.5.tar.gz 235284641 SHA256 2ef590bd71e94b32a827837d490d16f9037fa5f3d564045927eed919351f9b7f SHA512 0a40203b8a31c4d9288500962ada7f5083c280a84d8c56ab7da2d1326e1c02a908a96db589ab10bafc115abefe010bf23f6994c08e43c86a4ac10c2d4ab93ec2 WHIRLPOOL 4238648cc52342b0dd4cba452a6a54ee5a7271270c2948c9dfbe7689639b8433894dece50c83fa1e320c7a0f8e052432e2bc95c5375256d455c19274d6569b1f
diff --git a/dev-embedded/arduino/arduino-1.0.5-r2.ebuild b/dev-embedded/arduino/arduino-1.0.5-r2.ebuild
new file mode 100644
index 00000000000..7a1c2d55f1d
--- /dev/null
+++ b/dev-embedded/arduino/arduino-1.0.5-r2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+JAVA_PKG_IUSE="doc examples"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="An open-source AVR electronics prototyping platform"
+HOMEPAGE="http://arduino.cc/ https://github.com/arduino/"
+SRC_URI="
+ https://github.com/arduino/Arduino/archive/${PV}.tar.gz -> arduino-src-${PV}.tar.gz
+ mirror://gentoo/arduino-icons.tar.bz2
+"
+
+LICENSE="GPL-2 GPL-2+ LGPL-2 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip binchecks"
+
+S="${WORKDIR}/Arduino-${PV}"
+
+CDEPEND="
+ dev-java/jna:0
+ >dev-java/rxtx-2.1:2"
+
+RDEPEND="
+ ${CDEPEND}
+ dev-embedded/avrdude
+ dev-embedded/uisp
+ sys-devel/crossdev
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+EANT_GENTOO_CLASSPATH="jna,rxtx-2"
+EANT_EXTRA_ARGS="-Dversion=${PV}"
+EANT_BUILD_TARGET="build"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_prepare() {
+ # Remove the libraries to ensure the system
+ # libraries are used
+ rm -rv \
+ build/linux/dist/tools/avrdude* \
+ build/linux/dist/lib/* \
+ app/lib/* \
+ app/src/processing/app/macosx || die
+ # Patch build/build.xml - remove local jar files
+ # for rxtx and ecj (use system wide versions)
+ epatch \
+ "${FILESDIR}"/${PN}-1.0.1-build.xml.patch \
+ "${FILESDIR}"/${PN}-1.0.3-script.patch
+
+ default
+}
+
+src_compile() {
+ eant -f core/build.xml
+ EANT_GENTOO_CLASSPATH_EXTRA="../core/core.jar"
+ eant -f app/build.xml
+ eant "${EANT_EXTRA_ARGS}" -f build/build.xml
+}
+
+src_install() {
+ cd "${S}"/build/linux/work || die
+ java-pkg_dojar lib/core.jar lib/pde.jar
+ java-pkg_dolauncher ${PN} --pwd /usr/share/${PN} --main processing.app.Base
+
+ if use examples; then
+ java-pkg_doexamples examples
+ docompress -x /usr/share/doc/${PF}/examples/
+ fi
+
+ if use doc; then
+ DOCS=( revisions.txt "${S}"/readme.txt )
+ HTML_DOCS=( reference )
+ einstalldocs
+ java-pkg_dojavadoc "${S}"/build/javadoc/everything
+ fi
+
+ insinto "/usr/share/${PN}/"
+ doins -r hardware libraries
+ fowners -R root:uucp "/usr/share/${PN}/hardware"
+
+ insinto "/usr/share/${PN}/lib"
+ doins -r lib/*.txt lib/theme lib/*.jpg
+
+ # use system avrdude
+ # patching class files is too hard
+ dosym /usr/bin/avrdude "/usr/share/${PN}/hardware/tools/avrdude"
+ dosym /etc/avrdude.conf "/usr/share/${PN}/hardware/tools/avrdude.conf"
+
+ # install menu and icons
+ domenu "${FILESDIR}/${PN}.desktop"
+ for sz in 16 24 32 48 128 256; do
+ newicon -s $sz \
+ "${WORKDIR}/${PN}-icons/debian_icons_${sz}x${sz}_apps_${PN}.png" \
+ "${PN}.png"
+ done
+}
+
+pkg_postinst() {
+ [[ ! -x /usr/bin/avr-g++ ]] && ewarn "Missing avr-g++; you need to crossdev -s4 avr"
+}