summaryrefslogtreecommitdiff
path: root/dev-embedded/openocd/openocd-0.7.0-r1.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/openocd/openocd-0.7.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/openocd/openocd-0.7.0-r1.ebuild')
-rw-r--r--dev-embedded/openocd/openocd-0.7.0-r1.ebuild119
1 files changed, 119 insertions, 0 deletions
diff --git a/dev-embedded/openocd/openocd-0.7.0-r1.ebuild b/dev-embedded/openocd/openocd-0.7.0-r1.ebuild
new file mode 100644
index 00000000000..a8eca858c25
--- /dev/null
+++ b/dev-embedded/openocd/openocd-0.7.0-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib flag-o-matic toolchain-funcs
+
+# One ebuild to rule them all
+if [[ ${PV} == "9999" ]] ; then
+ inherit autotools git-2
+ KEYWORDS=""
+ EGIT_REPO_URI="git://git.code.sf.net/p/${PN}/code"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
+fi
+
+DESCRIPTION="OpenOCD - Open On-Chip Debugger"
+HOMEPAGE="http://openocd.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="blaster dummy ftd2xx ftdi minidriver parport presto segger stlink usb versaloon verbose-io"
+RESTRICT="strip" # includes non-native binaries
+
+# libftd2xx is the default because it is reported to work better.
+DEPEND=">=dev-lang/jimtcl-0.73
+ usb? ( virtual/libusb:0 )
+ presto? ( dev-embedded/libftd2xx )
+ ftd2xx? ( dev-embedded/libftd2xx )
+ ftdi? ( dev-embedded/libftdi )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="blaster? ( || ( ftdi ftd2xx ) ) ftdi? ( !ftd2xx )"
+
+src_prepare() {
+ epatch_user
+
+ if [[ ${PV} == "9999" ]] ; then
+ sed -i -e "/@include version.texi/d" doc/${PN}.texi || die
+ AT_NO_RECURSIVE=yes eautoreconf
+ fi
+
+ # Disable craptastic build settings.
+ sed -i \
+ -e 's:if test "[$]OCDxprefix" != "[$]ac_default_prefix":if false:' \
+ configure || die
+
+ if use ftdi ; then
+ local pc="libftdi$(has_version '=dev-embedded/libftdi-1*' && echo 1)"
+ # Use libftdi-1 paths #460916
+ local libs=$($(tc-getPKG_CONFIG) --libs ${pc})
+ sed -i \
+ -e "s:-lftdi -lusb:${libs}:" \
+ configure src/Makefile.in || die
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags ${pc})
+ fi
+}
+
+src_configure() {
+ # Here are some defaults
+ local myconf=(
+ --enable-buspirate
+ --enable-ioutil
+ --disable-werror
+ --disable-internal-jimtcl
+ --enable-amtjtagaccel
+ --enable-ep93xx
+ --enable-at91rm9200
+ --enable-gw16012
+ --enable-oocd_trace
+ --enable-ulink
+ --enable-arm-jtag-ew
+ --enable-ti-icdi
+ --enable-osbdm
+ --enable-opendous
+ )
+
+ if use usb; then
+ myconf+=(
+ --enable-usbprog
+ --enable-jlink
+ --enable-rlink
+ --enable-vsllink
+ --enable-arm-jtag-ew
+ $(use_enable verbose-io verbose-usb-io)
+ $(use_enable verbose-io verbose_usb_comms)
+ )
+ fi
+
+ # add explicitely the path to libftd2xx
+ use ftd2xx && append-ldflags -L/opt/$(get_libdir)
+
+ if use blaster; then
+ use ftdi && myconf+=( --enable-usb_blaster_libftdi )
+ use ftd2xx && myconf+=( --enable-usb_blaster_ftd2xx )
+ fi
+ econf \
+ $(use_enable dummy) \
+ $(use_enable ftdi ft2232_libftdi) \
+ $(use_enable ftdi) \
+ $(use_enable ftd2xx ft2232_ftd2xx) \
+ $(use_enable minidriver minidriver-dummy) \
+ $(use_enable parport) \
+ $(use_enable parport parport_ppdev) \
+ $(use_enable parport parport_giveio) \
+ $(use_enable presto presto_ftd2xx) \
+ $(use_enable segger jlink) \
+ $(use_enable stlink) \
+ $(use_enable versaloon vsllink) \
+ $(use_enable verbose-io verbose-jtag-io) \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+ env -uRESTRICT prepstrip "${ED}"/usr/bin "${ED}"/usr/$(get_libdir)
+}