summaryrefslogtreecommitdiff
path: root/dev-embedded/parapin
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/parapin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/parapin')
-rw-r--r--dev-embedded/parapin/Manifest1
-rw-r--r--dev-embedded/parapin/metadata.xml15
-rw-r--r--dev-embedded/parapin/parapin-1.0.0.ebuild40
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-embedded/parapin/Manifest b/dev-embedded/parapin/Manifest
new file mode 100644
index 00000000000..35e067cf387
--- /dev/null
+++ b/dev-embedded/parapin/Manifest
@@ -0,0 +1 @@
+DIST parapin-1.0.0.tar.gz 240771 SHA256 98060d8a7ccdffc924e564d6e2f1b8646614cf5753b7312ef917e7a09b2e2a6f SHA512 43e4066b649bec8519c98052451ab1beb720c9c8086bbd045bb013e3c12c7e83bf0411ac4b8e7006c3acbc6d1487b918d26df65b246469e6c7e008a0e26874d9 WHIRLPOOL 78d5e41cfabcacf9dfb194772cf3ce6cd5e6fa33e9887d86baf59495bfe314ea6462627b6beefd812386a2270035ed2c41384e3956053b84efdcc04917ae602b
diff --git a/dev-embedded/parapin/metadata.xml b/dev-embedded/parapin/metadata.xml
new file mode 100644
index 00000000000..55bc20922fa
--- /dev/null
+++ b/dev-embedded/parapin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-embedded</herd>
+ <longdescription>
+Parapin makes it easy to write C code under Linux that controls individual pins on a PC parallel port. This kind of control is very useful for
+electronics projects that use the PC's parallel port as a generic digital I/O interface. Parapin goes to great lengths to insulate the programmer
+from the somewhat complex parallel port programming interface provided by the PC hardware, making it easy to use the parallel port for digital
+I/O. By the same token, this abstraction also makes Parapin less useful in applications that need to actually use the parallel port as a parallel
+port (e.g., for talking to a printer).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">parapin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-embedded/parapin/parapin-1.0.0.ebuild b/dev-embedded/parapin/parapin-1.0.0.ebuild
new file mode 100644
index 00000000000..0b8ebb8f3ce
--- /dev/null
+++ b/dev-embedded/parapin/parapin-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A parallel port pin programming library"
+HOMEPAGE="http://parapin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+IUSE="doc"
+KEYWORDS="x86 ~amd64"
+
+SLOT="0"
+
+DEPEND="doc? ( dev-tex/latex2html )"
+RDEPEND=""
+
+src_compile() {
+ # Note 2.4 and 2.6 makefiles are identical for the targets used
+ emake -f Makefile-2.4 CC=$(tc-getCC) || die
+}
+
+src_install() {
+ dolib.a libparapin.a
+ insopts -m0444; insinto /usr/include; doins parapin.h
+
+ dodoc README
+ if use doc; then
+ cd doc
+ emake html
+ cd parapin
+ dohtml *.html *.css *.png
+
+ cd ${S}
+ docinto examples
+ dodoc examples/*.c
+ fi
+}