summaryrefslogtreecommitdiff
path: root/dev-games/ode
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/ode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/ode')
-rw-r--r--dev-games/ode/Manifest2
-rw-r--r--dev-games/ode/metadata.xml18
-rw-r--r--dev-games/ode/ode-0.11.1.ebuild73
-rw-r--r--dev-games/ode/ode-0.12.ebuild73
4 files changed, 166 insertions, 0 deletions
diff --git a/dev-games/ode/Manifest b/dev-games/ode/Manifest
new file mode 100644
index 00000000000..c6f2d2d1331
--- /dev/null
+++ b/dev-games/ode/Manifest
@@ -0,0 +1,2 @@
+DIST ode-0.11.1.tar.bz2 1720088 SHA256 877884a86a3d53f3c5f2e35fbd8a3dc23c20249f0636c76f6ef41f6bf57a03a1 SHA512 1e015231f4d01c68e7539144d197031cca23d4b58ea53733184a826ce23388956c428a53385254e7eed2c5d3fc28224a688eb13be7ea648bd78e186c8f203d37 WHIRLPOOL a77c4a61b1dd551911e87a2233f279ac5e6cdea9abf1704574f2a42ab683a426b7fc2a8e9b422f80ca379532b7d755cf7d28f1a47948dd80444cff8c7796cd32
+DIST ode-0.12.tar.bz2 1816246 SHA256 65c5315a42c725d2da01ea2c1b045583d54e0d1a95e3f7c062e5ba3769f5c350 SHA512 303ffda8afcb89a87d09c44393f590f5646f10e8959ca06746121859ad2407709cd711ab185fed4817a9f74c9ca4ee13d1698a28577211bf65dbaad1141f6fc0 WHIRLPOOL def7dfd7bb9f78db9c593bb99eb635da9868dd05362817ca344e583ca157da87c3e6932b9912684bc3deed2aff9eeb409d57fd9eb388e2f195f9c83b5cccabc4
diff --git a/dev-games/ode/metadata.xml b/dev-games/ode/metadata.xml
new file mode 100644
index 00000000000..0c0888501ff
--- /dev/null
+++ b/dev-games/ode/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+ODE is a free, industrial quality library for simulating articulated rigid body
+dynamics - for example ground vehicles, legged creatures, and moving objects in
+VR environments. It is fast, flexible, robust and platform independent, with
+advanced joints, contact with friction, and built-in collision detection.
+</longdescription>
+ <use>
+ <flag name="double-precision">more precise calculations at the expense of speed</flag>
+ <flag name="gyroscopic">enable gyroscopic term (may cause instability)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">opende</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-games/ode/ode-0.11.1.ebuild b/dev-games/ode/ode-0.11.1.ebuild
new file mode 100644
index 00000000000..c0de671f1bb
--- /dev/null
+++ b/dev-games/ode/ode-0.11.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Open Dynamics Engine SDK"
+HOMEPAGE="http://ode.org/"
+SRC_URI="mirror://sourceforge/opende/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="debug doc double-precision examples gyroscopic static-libs"
+
+RDEPEND="examples? (
+ virtual/opengl
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i \
+ -e "s:\$.*/drawstuff/textures:/usr/share/doc/${PF}/examples:" \
+ drawstuff/src/Makefile.in \
+ ode/demo/Makefile.in || die
+}
+
+src_configure() {
+ # use bash (bug #335760)
+ CONFIG_SHELL=/bin/bash \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug asserts) \
+ $(use_enable double-precision) \
+ $(use_enable examples demos) \
+ $(use_enable gyroscopic) \
+ $(use_with examples drawstuff X11)
+}
+
+src_compile() {
+ emake
+ if use doc ; then
+ cd ode/doc
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ DOCS="CHANGELOG.txt README.txt" \
+ default
+ prune_libtool_files
+ if use doc ; then
+ dohtml docs/*
+ fi
+ if use examples; then
+ cd ode/demo
+ exeinto /usr/share/doc/${PF}/examples
+ local f
+ for f in *.c* ; do
+ doexe .libs/${f%.*}
+ done
+ cd ../..
+ doexe drawstuff/dstest/dstest
+ insinto /usr/share/doc/${PF}/examples
+ doins ode/demo/*.{c,cpp,h} \
+ drawstuff/textures/*.ppm \
+ drawstuff/dstest/dstest.cpp \
+ drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
+ fi
+}
diff --git a/dev-games/ode/ode-0.12.ebuild b/dev-games/ode/ode-0.12.ebuild
new file mode 100644
index 00000000000..cecc087f472
--- /dev/null
+++ b/dev-games/ode/ode-0.12.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Open Dynamics Engine SDK"
+HOMEPAGE="http://ode.org/"
+SRC_URI="mirror://sourceforge/opende/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug doc double-precision examples gyroscopic static-libs"
+
+RDEPEND="examples? (
+ virtual/opengl
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i \
+ -e "s:\$.*/drawstuff/textures:/usr/share/doc/${PF}/examples:" \
+ drawstuff/src/Makefile.in \
+ ode/demo/Makefile.in || die
+}
+
+src_configure() {
+ # use bash (bug #335760)
+ CONFIG_SHELL=/bin/bash \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug asserts) \
+ $(use_enable double-precision) \
+ $(use_enable examples demos) \
+ $(use_enable gyroscopic) \
+ $(use_with examples drawstuff X11)
+}
+
+src_compile() {
+ emake
+ if use doc ; then
+ cd ode/doc
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ DOCS="CHANGELOG.txt README.txt" \
+ default
+ prune_libtool_files
+ if use doc ; then
+ dohtml docs/*
+ fi
+ if use examples; then
+ cd ode/demo
+ exeinto /usr/share/doc/${PF}/examples
+ local f
+ for f in *.c* ; do
+ doexe .libs/${f%.*}
+ done
+ cd ../..
+ doexe drawstuff/dstest/dstest
+ insinto /usr/share/doc/${PF}/examples
+ doins ode/demo/*.{c,cpp,h} \
+ drawstuff/textures/*.ppm \
+ drawstuff/dstest/dstest.cpp \
+ drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
+ fi
+}