summaryrefslogtreecommitdiff
path: root/dev-games/t4k-common
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/t4k-common
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/t4k-common')
-rw-r--r--dev-games/t4k-common/Manifest1
-rw-r--r--dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch18
-rw-r--r--dev-games/t4k-common/metadata.xml6
-rw-r--r--dev-games/t4k-common/t4k-common-0.1.1.ebuild47
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-games/t4k-common/Manifest b/dev-games/t4k-common/Manifest
new file mode 100644
index 00000000000..fac74abea9d
--- /dev/null
+++ b/dev-games/t4k-common/Manifest
@@ -0,0 +1 @@
+DIST t4k_common-0.1.1.tar.gz 629215 SHA256 42c155816dae2c5dad560faa50edaa1ca84536530283d37859c4b91e82675110 SHA512 ddf9c0ccf1b6a4ab9f009794262fef86587e31e5110e5a8041214d7c94c607b9f4ca5ec21f04254bfc00a625ab75a04a69b3dcaff9ec13dbb92d5d82b6e375cf WHIRLPOOL 689ea91fea9323b468377eb2ed0c71fbef90527959d65304d110ce70ca62e6173dd010cd449b23785d4a3bc9f2c5c63272ecc8a8032068073a5deec93ae3a7b0
diff --git a/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch b/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
new file mode 100644
index 00000000000..29991544ddb
--- /dev/null
+++ b/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
@@ -0,0 +1,18 @@
+--- src/t4k_common-0.1.1/src/t4k_loaders.c 2011-04-08 05:46:07.000000000 +0300
++++ src.new/t4k_common-0.1.1/src/t4k_loaders.c 2012-05-02 10:35:41.836670434 +0300
+@@ -1028,12 +1028,9 @@
+ {
+ png_init_io(png_ptr, fi);
+
+- info_ptr->width = surf->w;
+- info_ptr->height = surf->h;
+- info_ptr->bit_depth = 8;
+- info_ptr->color_type = PNG_COLOR_TYPE_RGB_ALPHA;
+- info_ptr->interlace_type = 1;
+- info_ptr->valid = 0; /* will be updated by various png_set_FOO() functions */
++ png_set_IHDR(png_ptr, info_ptr, surf->w, surf->h, 8,
++ PNG_COLOR_TYPE_RGB_ALPHA, 1,
++ PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
+
+ png_set_sRGB_gAMA_and_cHRM(png_ptr, info_ptr,
+ PNG_sRGB_INTENT_PERCEPTUAL);
diff --git a/dev-games/t4k-common/metadata.xml b/dev-games/t4k-common/metadata.xml
new file mode 100644
index 00000000000..01a746edb19
--- /dev/null
+++ b/dev-games/t4k-common/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
+
diff --git a/dev-games/t4k-common/t4k-common-0.1.1.ebuild b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
new file mode 100644
index 00000000000..98732eb9625
--- /dev/null
+++ b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A library of code shared between tuxmath and tuxtype"
+HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/download.php"
+SRC_URI="http://alioth.debian.org/frs/download.php/3540/t4k_common-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs svg"
+
+RDEPEND="dev-libs/libxml2:2
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-pango
+ svg? (
+ gnome-base/librsvg:2
+ media-libs/libpng:0
+ x11-libs/cairo
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/t4k_common-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng.patch
+}
+
+src_configure() {
+ econf \
+ $(usex svg "" "--without-rsvg") \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+}