summaryrefslogtreecommitdiff
path: root/dev-go/go-text
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-03-19 13:17:47 -0700
committerZac Medico <zmedico@gentoo.org>2019-03-19 13:17:52 -0700
commit30cdd8569e83c15fa24520ccc3cdb9dafe1f2342 (patch)
tree60e11905c885fa825ebf8378ac4949d1e88f6527 /dev-go/go-text
parent1d87dbb01efa5064a5f571fac76150e195bd5716 (diff)
downloadgentoo-30cdd8569e83c15fa24520ccc3cdb9dafe1f2342.tar.gz
gentoo-30cdd8569e83c15fa24520ccc3cdb9dafe1f2342.tar.xz
dev-go/go-text: filter GOCACHE vars (bug 680946)
Reported-by: Toralf Förster <toralf@gentoo.org> Closes: https://bugs.gentoo.org/680946 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-go/go-text')
-rw-r--r--dev-go/go-text/go-text-0.3.0.ebuild3
-rw-r--r--dev-go/go-text/go-text-0_pre20160211.ebuild3
-rw-r--r--dev-go/go-text/go-text-9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/dev-go/go-text/go-text-0.3.0.ebuild b/dev-go/go-text/go-text-0.3.0.ebuild
index 84a3b008c10..c590eadea63 100644
--- a/dev-go/go-text/go-text-0.3.0.ebuild
+++ b/dev-go/go-text/go-text-0.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ DEPEND=">=dev-go/go-tools-0_pre20180817"
RDEPEND=""
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #680946
# Create an isolated golibdir in order to avoid an
# "use of internal package not allowed" error when
# and older version is installed.
diff --git a/dev-go/go-text/go-text-0_pre20160211.ebuild b/dev-go/go-text/go-text-0_pre20160211.ebuild
index 979b835ba8c..a723fc4cfc5 100644
--- a/dev-go/go-text/go-text-0_pre20160211.ebuild
+++ b/dev-go/go-text/go-text-0_pre20160211.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,6 +25,7 @@ DEPEND=""
RDEPEND=""
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #680946
# Create a writable GOROOT in order to avoid sandbox violations.
cp -sR "$(go env GOROOT)" "${T}/goroot" || die
rm -rf "${T}/goroot/src/${EGO_SRC}" || die
diff --git a/dev-go/go-text/go-text-9999.ebuild b/dev-go/go-text/go-text-9999.ebuild
index 4d851787c26..0740869fb57 100644
--- a/dev-go/go-text/go-text-9999.ebuild
+++ b/dev-go/go-text/go-text-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,6 +25,7 @@ DEPEND=">=dev-go/go-tools-0_pre20180817"
RDEPEND=""
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #680946
# Create an isolated golibdir in order to avoid an
# "use of internal package not allowed" error when
# and older version is installed.