summaryrefslogtreecommitdiff
path: root/dev-go/goptlib/goptlib-0.5.ebuild
diff options
context:
space:
mode:
authorMarek Szuba <Marek.Szuba@cern.ch>2016-04-21 15:11:57 +0200
committerAnthony G. Basile <blueness@gentoo.org>2016-04-23 02:49:55 -0400
commit4333ea40c3d2b7c18abd18d73816763022e1b613 (patch)
treebfde677fb6fbfe17dfe1b6800c1b504bee4cfe75 /dev-go/goptlib/goptlib-0.5.ebuild
parent5b8d9c067a21fe4feb6fbecfe4155c36c44b989b (diff)
downloadgentoo-4333ea40c3d2b7c18abd18d73816763022e1b613.tar.gz
gentoo-4333ea40c3d2b7c18abd18d73816763022e1b613.tar.xz
New ebuild: dev-go/goptlib.
The official Go library for Tor pluggable transports. This is one of the dependencies of net-proxy/obfs4proxy. Relevant Gentoo bug: #580626.
Diffstat (limited to 'dev-go/goptlib/goptlib-0.5.ebuild')
-rw-r--r--dev-go/goptlib/goptlib-0.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-go/goptlib/goptlib-0.5.ebuild b/dev-go/goptlib/goptlib-0.5.ebuild
new file mode 100644
index 00000000000..3d2eaba8a8b
--- /dev/null
+++ b/dev-go/goptlib/goptlib-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit golang-build golang-vcs-snapshot
+
+EGO_SRC=git.torproject.org/pluggable-transports/goptlib.git
+EGO_PN=${EGO_SRC}/...
+EGIT_COMMIT="${PV}"
+
+DESCRIPTION="Go Tor pluggable transports library"
+HOMEPAGE="https://gitweb.torproject.org/pluggable-transports/goptlib.git"
+# No official tarballs; see https://trac.torproject.org/projects/tor/ticket/18504
+SRC_URI="mirror://debian/pool/main/g/golang-${PN}/golang-${P/-/_}.orig.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""