summaryrefslogtreecommitdiff
path: root/dev-go/goptlib/goptlib-0.5.ebuild
diff options
context:
space:
mode:
authorMarek Szuba <Marek.Szuba@cern.ch>2016-04-21 11:57:19 +0200
committerAnthony G. Basile <blueness@gentoo.org>2016-04-23 02:49:46 -0400
commit81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5 (patch)
tree3b63ce26c2ac0f3294f718766a1ad9ccda6eb271 /dev-go/goptlib/goptlib-0.5.ebuild
parente9a6b95c48c57f0cde265333351d638724d66a91 (diff)
downloadgentoo-81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5.tar.gz
gentoo-81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5.tar.xz
New ebuild: net-proxy/obfs4proxy, plus dependencies.
A new obfuscating proxy for Tor bridges which supports, among others, the OBFS4 protocol. It depends on three packages which were not in Portage and therefore have just had ebuild files created as well: dev-go/ed25519, dev-go/goptlib, and dev-go/siphash. Relevant Gentoo bugs: #580582, #580622, #580626, #580628.
Diffstat (limited to 'dev-go/goptlib/goptlib-0.5.ebuild')
-rw-r--r--dev-go/goptlib/goptlib-0.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-go/goptlib/goptlib-0.5.ebuild b/dev-go/goptlib/goptlib-0.5.ebuild
new file mode 100644
index 00000000000..3d2eaba8a8b
--- /dev/null
+++ b/dev-go/goptlib/goptlib-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit golang-build golang-vcs-snapshot
+
+EGO_SRC=git.torproject.org/pluggable-transports/goptlib.git
+EGO_PN=${EGO_SRC}/...
+EGIT_COMMIT="${PV}"
+
+DESCRIPTION="Go Tor pluggable transports library"
+HOMEPAGE="https://gitweb.torproject.org/pluggable-transports/goptlib.git"
+# No official tarballs; see https://trac.torproject.org/projects/tor/ticket/18504
+SRC_URI="mirror://debian/pool/main/g/golang-${PN}/golang-${P/-/_}.orig.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""