summaryrefslogtreecommitdiff
path: root/dev-haskell/abstract-deque
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/abstract-deque
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/abstract-deque')
-rw-r--r--dev-haskell/abstract-deque/Manifest2
-rw-r--r--dev-haskell/abstract-deque/abstract-deque-0.2.2.ebuild32
-rw-r--r--dev-haskell/abstract-deque/abstract-deque-0.3.ebuild32
-rw-r--r--dev-haskell/abstract-deque/metadata.xml31
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-haskell/abstract-deque/Manifest b/dev-haskell/abstract-deque/Manifest
new file mode 100644
index 00000000000..22b113b54c2
--- /dev/null
+++ b/dev-haskell/abstract-deque/Manifest
@@ -0,0 +1,2 @@
+DIST abstract-deque-0.2.2.tar.gz 15771 SHA256 cb6fda5c6f38535d14b9132ff7e9184019099b47f510a164e272da54e4f0e489 SHA512 0a572a4943b90c7a99955f522b790c1ba3149f29ff072927d4f49013e174491a48312dcbbc45df271196d8f90725ea1b9ecc60ed218f71646bbb703555ded1b9 WHIRLPOOL 0447e669206eff27d4446d28163ca434ff8fa094049c046f181823cc23ba312a268184e0ae59cb19249c9b2a332264d68d171ad07fdcd923c6f6eb5fe2163c4a
+DIST abstract-deque-0.3.tar.gz 7219 SHA256 09aa10f38193a8275a7791b92a4f3a7192a304874637e2a35c897dde25d75ca2 SHA512 9293a366918f54458ffe13f6737bab2bee961b730732eff563d900b451bf5f7dde30276c9406bfc5c0ea64104afb70db3588b13d478bf9c60842dad906195f7a WHIRLPOOL 0c4155a607ee55fb4b78175fde27ff853e455ca267a37ea2372d0c54e38cbc78f7d2955edbc98b6012fcc3a5533d3a1c42b6aed2ec555cad82754b3af9281715
diff --git a/dev-haskell/abstract-deque/abstract-deque-0.2.2.ebuild b/dev-haskell/abstract-deque/abstract-deque-0.2.2.ebuild
new file mode 100644
index 00000000000..72846e017b8
--- /dev/null
+++ b/dev-haskell/abstract-deque/abstract-deque-0.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Abstract, parameterized interface to mutable Deques"
+HOMEPAGE="https://github.com/rrnewton/haskell-lockfree-queue/wiki"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="usecas"
+
+RDEPEND="dev-haskell/hunit:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/test-framework-0.6:=[profile?]
+ >=dev-haskell/test-framework-hunit-0.2.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag usecas usecas)
+}
diff --git a/dev-haskell/abstract-deque/abstract-deque-0.3.ebuild b/dev-haskell/abstract-deque/abstract-deque-0.3.ebuild
new file mode 100644
index 00000000000..fe3065f15d3
--- /dev/null
+++ b/dev-haskell/abstract-deque/abstract-deque-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Abstract, parameterized interface to mutable Deques"
+HOMEPAGE="https://github.com/rrnewton/haskell-lockfree/wiki"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="usecas"
+
+RDEPEND="dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ usecas? ( >=dev-haskell/atomic-primops-0.5.0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag usecas usecas)
+}
diff --git a/dev-haskell/abstract-deque/metadata.xml b/dev-haskell/abstract-deque/metadata.xml
new file mode 100644
index 00000000000..2725ffafd7c
--- /dev/null
+++ b/dev-haskell/abstract-deque/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ An abstract interface to highly-parameterizable queues/deques.
+
+ Background: There exists a feature space for queues that extends between:
+
+ * simple, single-ended, non-concurrent, bounded queues
+
+ * double-ended, threadsafe, growable queues
+
+ ... with important points inbetween (such as
+ the queues used for work-stealing).
+
+ This package includes an interface for Deques that allows the
+ programmer to use a single API for all of the above, while using the
+ type-system to select an efficient implementation given the
+ requirements (using type families).
+
+ This package also includes a simple reference implementation based
+ on 'IORef' and "Data.Sequence".
+ </longdescription>
+ <use>
+ <flag name="usecas"> Enable the reference implementation to use hardware compare-and-swap.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">rrnewton/haskell-lockfree</remote-id>
+ </upstream>
+</pkgmetadata>