summaryrefslogtreecommitdiff
path: root/dev-haskell/arithmoi
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-11 14:56:59 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-11 14:56:59 +0100
commit5de3d66f6fe264195d6b8cd0098343a3b8751114 (patch)
treee69a35f1d86d79c0996400a7862ababe9f458097 /dev-haskell/arithmoi
parentfbbc48a6ac940eee23d92e77a633ec07bc7d6a57 (diff)
downloadgentoo-5de3d66f6fe264195d6b8cd0098343a3b8751114.tar.gz
gentoo-5de3d66f6fe264195d6b8cd0098343a3b8751114.tar.xz
dev-haskell/arithmoi: bump up to 0.4.2.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-haskell/arithmoi')
-rw-r--r--dev-haskell/arithmoi/Manifest1
-rw-r--r--dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/arithmoi/Manifest b/dev-haskell/arithmoi/Manifest
index 8f8f9bd8233..0b180367018 100644
--- a/dev-haskell/arithmoi/Manifest
+++ b/dev-haskell/arithmoi/Manifest
@@ -1 +1,2 @@
DIST arithmoi-0.4.1.3.tar.gz 66196 SHA256 2e623924079d3f8733fd31bf40a30ee0051dd0c3e3ae4b13a7afb5f2300413c9 SHA512 abc5939207e502dffd91b3a4e2b9c688eef388a6b9354576fcb4badf4625da1cad0e9698cb42b293b37cc29427ad2679170452374fbf6cd5e614d53db34cd9f6 WHIRLPOOL dc0c167e63430d8f57fef7107f8444fa2fb1e76a5664043524df6c606f778cbecb457c43d9b1484015b96d4f91c221e60718f637593362ad657e7c5a5ae24a48
+DIST arithmoi-0.4.2.0.tar.gz 84676 SHA256 6cc6ade285cdbd437c3e5587e588d4d55152a273e9c276a4679cc22a6e1d2a88 SHA512 687f12aef8baf98c778498b9a0bb33f0ac3175d009ba8dcd14d6ff8bb13252120f6821e80932410a1413637b591f81b92e0ecd25cd7870464e1629f3d0bf866c WHIRLPOOL 4b852e9349371512901fb5f5f15a11e871e809e56620e71dce9e68969e23ee6978f5c24733d7373a4debd4df75ffc96bbdecff3056b490ee55a6b737a70fe58f
diff --git a/dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild b/dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild
new file mode 100644
index 00000000000..f5251dfffaa
--- /dev/null
+++ b/dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -check-bounds
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient basic number-theoretic functions. Primes, powers, integer logarithms"
+HOMEPAGE="https://github.com/cartazio/arithmoi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.8 <dev-haskell/quickcheck-2.9
+ >=dev-haskell/smallcheck-1.1 <dev-haskell/smallcheck-1.2
+ >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9
+ >=dev-haskell/tasty-smallcheck-0.8 <dev-haskell/tasty-smallcheck-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-check-bounds
+}