summaryrefslogtreecommitdiff
path: root/dev-haskell/asn1-data
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/asn1-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/asn1-data')
-rw-r--r--dev-haskell/asn1-data/Manifest1
-rw-r--r--dev-haskell/asn1-data/asn1-data-0.7.1-r1.ebuild32
-rw-r--r--dev-haskell/asn1-data/asn1-data-0.7.1.ebuild26
-rw-r--r--dev-haskell/asn1-data/files/asn1-data-0.7.1-ghc-7.10.patch16
-rw-r--r--dev-haskell/asn1-data/metadata.xml13
5 files changed, 88 insertions, 0 deletions
diff --git a/dev-haskell/asn1-data/Manifest b/dev-haskell/asn1-data/Manifest
new file mode 100644
index 00000000000..d532e0a64cb
--- /dev/null
+++ b/dev-haskell/asn1-data/Manifest
@@ -0,0 +1 @@
+DIST asn1-data-0.7.1.tar.gz 17500 SHA256 f9a8a8ec41e89ebb4af6bd6b8a4c45515e44d7d61524d02b52881bfe7caf4783 SHA512 dc6021daf15e5f9b93703641780c6d81c6b385d2127bcc2f735ecaf54d1be5163ad5e9ae291a3e223ff05cf03e8bbf11af0791ee810a0ba174e9cc9e9fd910d0 WHIRLPOOL 73a1e7f32c0e98bf52f1641214c6b69ae4336e24e0b0ac08eda04dc48f03085eb1a7c9e3ab2ddea9e25001e1841efb25b70adaefdc23f37130fc69ed8a46bc76
diff --git a/dev-haskell/asn1-data/asn1-data-0.7.1-r1.ebuild b/dev-haskell/asn1-data/asn1-data-0.7.1-r1.ebuild
new file mode 100644
index 00000000000..4c4924ea92f
--- /dev/null
+++ b/dev-haskell/asn1-data/asn1-data-0.7.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="http://github.com/vincenthz/hs-asn1-data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}
diff --git a/dev-haskell/asn1-data/asn1-data-0.7.1.ebuild b/dev-haskell/asn1-data/asn1-data-0.7.1.ebuild
new file mode 100644
index 00000000000..8341128049d
--- /dev/null
+++ b/dev-haskell/asn1-data/asn1-data-0.7.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="http://github.com/vincenthz/hs-asn1-data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal[profile?]
+ dev-haskell/mtl[profile?]
+ >=dev-haskell/text-0.11[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/asn1-data/files/asn1-data-0.7.1-ghc-7.10.patch b/dev-haskell/asn1-data/files/asn1-data-0.7.1-ghc-7.10.patch
new file mode 100644
index 00000000000..8bf958454be
--- /dev/null
+++ b/dev-haskell/asn1-data/files/asn1-data-0.7.1-ghc-7.10.patch
@@ -0,0 +1,16 @@
+diff --git a/Data/ASN1/Parse.hs b/Data/ASN1/Parse.hs
+index eeea2be..83bc80e 100644
+--- a/Data/ASN1/Parse.hs
++++ b/Data/ASN1/Parse.hs
+@@ -24 +24 @@ import Control.Monad.Error
+-import Control.Applicative ((<$>))
++import Control.Applicative ((<$>), Applicative)
+@@ -25,7 +25,7 @@ import Control.Applicative ((<$>))
+
+ -- | Parse ASN1 Monad
+ newtype ParseASN1 a = P { runP :: ErrorT String (State [ASN1]) a }
+- deriving (Functor, Monad, MonadError String)
++ deriving (Functor, Applicative, Monad, MonadError String)
+
+ -- | run the parse monad over a stream and returns the result and the remaining ASN1 Stream.
+ runParseASN1State :: ParseASN1 a -> [ASN1] -> Either String (a,[ASN1])
diff --git a/dev-haskell/asn1-data/metadata.xml b/dev-haskell/asn1-data/metadata.xml
new file mode 100644
index 00000000000..e80a0526806
--- /dev/null
+++ b/dev-haskell/asn1-data/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ ASN1 data reader and writer in raw form with supports for high level forms of ASN1 (BER, CER and DER).
+
+ All interfaces use the enumerator interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-asn1-data</remote-id>
+ </upstream>
+</pkgmetadata>