summaryrefslogtreecommitdiff
path: root/dev-haskell/async
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/async
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/async')
-rw-r--r--dev-haskell/async/Manifest4
-rw-r--r--dev-haskell/async/async-2.0.1.4.ebuild34
-rw-r--r--dev-haskell/async/async-2.0.1.5.ebuild29
-rw-r--r--dev-haskell/async/async-2.0.1.6.ebuild29
-rw-r--r--dev-haskell/async/async-2.0.2.ebuild29
-rw-r--r--dev-haskell/async/metadata.xml55
6 files changed, 180 insertions, 0 deletions
diff --git a/dev-haskell/async/Manifest b/dev-haskell/async/Manifest
new file mode 100644
index 00000000000..d2a98290c89
--- /dev/null
+++ b/dev-haskell/async/Manifest
@@ -0,0 +1,4 @@
+DIST async-2.0.1.4.tar.gz 8349 SHA256 41ddfe012d98f3ef101651fb529753bca5bb4c804f03f9cfafc5d0cbe50224c2 SHA512 8b170644ce92f9788e22771239542e46ee14b9898404744f6a97b955ef22ae4b3fa280ea759f228cb22f2083b5ee007f39c61063f82e5cce8f6bf1c6df789a71 WHIRLPOOL 3f95800777b3efb160b1bbe4356d9fa2a76b7bc0e6143fce8823b062854a42c465ab2d84c2c695592ef78a9cc831428807342b2c7a86d2e0ff0750bccf53b622
+DIST async-2.0.1.5.tar.gz 8350 SHA256 cd13ac558f4f63e567100805770648e89307a3210852b17038c9be4fcc3aa83c SHA512 58004930b12bd6aafc09db56dcbdd1071b94bdfea1c55f1ba0854c17b61054e272aa8c3edac05bcf34ee39c63318ffca26680215748994e8ae604b600b0563fc WHIRLPOOL 554371e386c5f2dea18a2b678bd2a47a0faefc95079842a2cfd60971b20f744966bd335d52b44a35b37f376cf9c44d9a3912bf109fc6b4137bc200bcfef71a33
+DIST async-2.0.1.6.tar.gz 8518 SHA256 7fca19e99fd4771fead99ff764497993f2e15c0ffbe8fa7cc49db148259edf19 SHA512 a3be9d86cc27e7c1b168c4b461f7af9097cab7b6bd9045fbf86aa89e4ec7e63e5ee95d628172ce8a6a8dd7a76902d3ff15ae22acfe12a97d081a79fddc3f1c74 WHIRLPOOL 5cdd7a2a4fa3345027ae83acd994192fa4cf03b2b5cfa32bc320cbf82769f8004968404df5f483e1a79409d51ca1373c1b1185dc5ba266ae13c68deee0beae1a
+DIST async-2.0.2.tar.gz 8565 SHA256 db54d384259eee2f3ca525821f45fe509b9a101fbf3a8df7132aa9622626fd2b SHA512 beac3452aca98f9c41fb86b1b9e105a324df5a05e10c7d616927bb94888d6d2ed5385e0ec901fdfa050a43e991f5089757d3941ce97db98c148a159893bddc1e WHIRLPOOL 2fabce8ef356ab478db333d042d69dbe9233d6bdaba95e336095343c821f9476aaea09c22b1cf6a6e61cb5ae8c7d7df60d8a4ee232e13a20111d5ba6bfcad031
diff --git a/dev-haskell/async/async-2.0.1.4.ebuild b/dev-haskell/async/async-2.0.1.4.ebuild
new file mode 100644
index 00000000000..643cc04b1b5
--- /dev/null
+++ b/dev-haskell/async/async-2.0.1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?]
+ <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:="
+DEPEND="${RDEPEND}
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ )
+ >=dev-haskell/cabal-1.8"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.3 && < 4.7' 'base >= 4.3'
+}
diff --git a/dev-haskell/async/async-2.0.1.5.ebuild b/dev-haskell/async/async-2.0.1.5.ebuild
new file mode 100644
index 00000000000..c6bdfc92bb5
--- /dev/null
+++ b/dev-haskell/async/async-2.0.1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
diff --git a/dev-haskell/async/async-2.0.1.6.ebuild b/dev-haskell/async/async-2.0.1.6.ebuild
new file mode 100644
index 00000000000..daeea829f9f
--- /dev/null
+++ b/dev-haskell/async/async-2.0.1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
diff --git a/dev-haskell/async/async-2.0.2.ebuild b/dev-haskell/async/async-2.0.2.ebuild
new file mode 100644
index 00000000000..1fc926b57c0
--- /dev/null
+++ b/dev-haskell/async/async-2.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
diff --git a/dev-haskell/async/metadata.xml b/dev-haskell/async/metadata.xml
new file mode 100644
index 00000000000..53ad7597252
--- /dev/null
+++ b/dev-haskell/async/metadata.xml
@@ -0,0 +1,55 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides a higher-level interface over
+ threads, in which an @Async a@ is a concurrent
+ thread that will eventually deliver a value of
+ type @a@. The package provides ways to create
+ @Async@ computations, wait for their results, and
+ cancel them.
+
+ Using @Async@ is safer than using threads in two
+ ways:
+
+ * When waiting for a thread to return a result,
+ if the thread dies with an exception then the
+ caller must either re-throw the exception
+ ('wait') or handle it ('waitCatch'); the
+ exception cannot be ignored.
+
+ * The API makes it possible to build a tree of
+ threads that are automatically killed when
+ their parent dies (see 'withAsync').
+
+ Changes in 2.0.1.3:
+
+ * Bump @base@ dependency to allow 4.6
+
+ Changes in 2.0.1.2:
+
+ * Bump @stm@ dependency to 2.4
+
+ Changes in 2.0.1.1:
+
+ * Safe Haskell support: @Control.Concurrent.Async@ is now @Trustworthy@
+
+ Changes in 2.0.1.0:
+
+ * Added a @Functor@ instance for @Async@
+
+ * Added @asyncBound@, @asyncOn@, @asyncWithUnmask@, @asyncOnWithUnmask@, @withAsyncBound@, @withAsyncOn@, @withAsyncWithUnmask@, @withAsyncOnWithUnmask@.
+
+ * Added @mapConcurrently@
+
+ * Added @Concurrently@ (with @Applicative@ and @Alternative@ instances)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">simonmar/async</remote-id>
+ </upstream>
+</pkgmetadata>