summaryrefslogtreecommitdiff
path: root/dev-haskell/binary
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/binary
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/binary')
-rw-r--r--dev-haskell/binary/Manifest4
-rw-r--r--dev-haskell/binary/binary-0.5.1.1.ebuild25
-rw-r--r--dev-haskell/binary/binary-0.7.1.0.ebuild39
-rw-r--r--dev-haskell/binary/binary-0.7.2.3.ebuild32
-rw-r--r--dev-haskell/binary/binary-0.7.5.0.ebuild33
-rw-r--r--dev-haskell/binary/metadata.xml16
6 files changed, 149 insertions, 0 deletions
diff --git a/dev-haskell/binary/Manifest b/dev-haskell/binary/Manifest
new file mode 100644
index 00000000000..986972245f2
--- /dev/null
+++ b/dev-haskell/binary/Manifest
@@ -0,0 +1,4 @@
+DIST binary-0.5.1.1.tar.gz 34239 SHA256 945d62a0ea0bd5b5345cce88e6c337b116485334d2b0591b449773a14452c268 SHA512 a177770f2fc220402d2ab256f47ead219176709ecada9994ad5b70a22d9c613e98b4d3b513f45ec4f684d2458e8971c71b0b30cf2d76a79224a424f56360a334 WHIRLPOOL 594399b5945b5d4e40c1696e5962dddd3e84053249cd1dce970f7c302c479320edcdc3fb2b0b9cca13409cad6f1dbc25145aeb21b3b8069216451a13dbffec0f
+DIST binary-0.7.1.0.tar.gz 43647 SHA256 9622efca717cd4f606dc3f43e93464b6eeb0f35e12dd0207065cc6533e498b99 SHA512 711d64c51cb6cf8811252fe3cbb0575dade897666566610f8dee51c2965d0e3dc1dc40df72713e9e6abbd0bfe494dd4feee70128d21f1ea16305bde3409557b3 WHIRLPOOL f748f3baff58e236be0dfaa4855716f85b702ef08f3ab28550cd1ecd4dd018cd7f6fc72caa35b34cd6f0f4016f49c104367f7970f5f923440dff2f074cbe9b4a
+DIST binary-0.7.2.3.tar.gz 47622 SHA256 fd7f59302cbb137068de28efe6e2c403fa45c10077641ec33fa1fb09a8a5c499 SHA512 1babe32d1c2c0537091c96a3191285f2f61a9c85ca503c89c57c32e60d8f16ee429dd8fb645563d96714122a06ca6c9f0ab1c04077b4f0ed22d4b0b41ef2c18f WHIRLPOOL d7bfb011e830553a3284b2dfebffcf18d4d10fda194fe135d6e5aa9b5145c61e406600904b72f57149ecfee58a0ba928cc3ffa62d8eb7cba8660326bf5667755
+DIST binary-0.7.5.0.tar.gz 45764 SHA256 4709c5aa7cc99cb4a465a68de1648968208d0c60c368e2fece476d977530ef19 SHA512 232e7c3da1c0055f3e9f211a86e81c76bc44ab1b70cabd23c93634dbaa42eed8bd9314fbedc16b9703d3ca92b0bbf232e6c30bb1384687dad0e6e85c9abb8947 WHIRLPOOL 1d8dcf9d5125ff398375f4024c0e43fa168004811db7824e2739ec5c0451b38dae9ad74f757c7708427deed0044580b182e35d1c7ecffec25f7b10c70bd32075
diff --git a/dev-haskell/binary/binary-0.5.1.1.ebuild b/dev-haskell/binary/binary-0.5.1.1.ebuild
new file mode 100644
index 00000000000..4fb5ac70949
--- /dev/null
+++ b/dev-haskell/binary/binary-0.5.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.2.19.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
+HOMEPAGE="http://code.haskell.org/binary/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+CABAL_CORE_LIB_GHC_PV="7.6.* 7.7.*"
diff --git a/dev-haskell/binary/binary-0.7.1.0.ebuild b/dev-haskell/binary/binary-0.7.1.0.ebuild
new file mode 100644
index 00000000000..7ee867db7da
--- /dev/null
+++ b/dev-haskell/binary/binary-0.7.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
+HOMEPAGE="https://github.com/kolmodin/binary"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ >=dev-haskell/random-1.0.1.0
+ dev-haskell/test-framework
+ >=dev-haskell/test-framework-quickcheck2-0.3
+ )"
+
+CABAL_CORE_LIB_GHC_PV="7.7.2013* 7.8.20140130 7.8.0.20140228 7.8.1 7.8.2 7.8.3 7.8.4"
+
+src_prepare() {
+ if has_version ">=dev-lang/ghc-7.7"; then
+ sed -e '/test-suite read-write-file/,/ghc-options: -Wall/d' \
+ -i "${S}/${PN}.cabal" \
+ || die "Could not remove test suite for ghc 7.7"
+ fi
+}
diff --git a/dev-haskell/binary/binary-0.7.2.3.ebuild b/dev-haskell/binary/binary-0.7.2.3.ebuild
new file mode 100644
index 00000000000..5e426b638a4
--- /dev/null
+++ b/dev-haskell/binary/binary-0.7.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
+HOMEPAGE="https://github.com/kolmodin/binary"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/random-1.0.1.0
+ dev-haskell/test-framework
+ >=dev-haskell/test-framework-quickcheck2-0.3 )
+"
+
+CABAL_CORE_LIB_GHC_PV="7.10.* 7.11.2015*"
diff --git a/dev-haskell/binary/binary-0.7.5.0.ebuild b/dev-haskell/binary/binary-0.7.5.0.ebuild
new file mode 100644
index 00000000000..abe7e33e7aa
--- /dev/null
+++ b/dev-haskell/binary/binary-0.7.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
+HOMEPAGE="https://github.com/kolmodin/binary"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with latest ghc-7.10
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.8
+ >=dev-haskell/random-1.0.1.0
+ dev-haskell/test-framework
+ >=dev-haskell/test-framework-quickcheck2-0.3 )
+"
+
+CABAL_CORE_LIB_GHC_PV="PM:7.10.2_rc2 PM:7.10.2"
diff --git a/dev-haskell/binary/metadata.xml b/dev-haskell/binary/metadata.xml
new file mode 100644
index 00000000000..a1894f70a5c
--- /dev/null
+++ b/dev-haskell/binary/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Efficient, pure binary serialisation using lazy ByteStrings.
+ Haskell values may be encoded to and from binary formats,
+ written to disk as binary, or sent over the network.
+ Serialisation speeds of over 1 G\/sec have been observed,
+ so this library should be suitable for high performance
+ scenarios.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kolmodin/binary</remote-id>
+ </upstream>
+</pkgmetadata>