summaryrefslogtreecommitdiff
path: root/dev-haskell/bio
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/bio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/bio')
-rw-r--r--dev-haskell/bio/Manifest1
-rw-r--r--dev-haskell/bio/bio-0.5.3-r1.ebuild63
-rw-r--r--dev-haskell/bio/bio-0.5.3.ebuild61
-rw-r--r--dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch7
-rw-r--r--dev-haskell/bio/metadata.xml22
5 files changed, 154 insertions, 0 deletions
diff --git a/dev-haskell/bio/Manifest b/dev-haskell/bio/Manifest
new file mode 100644
index 00000000000..1ac6c5cad49
--- /dev/null
+++ b/dev-haskell/bio/Manifest
@@ -0,0 +1 @@
+DIST bio-0.5.3.tar.gz 103707 SHA256 42c8f9b83fea6bf51356afe1251910ba4421e0af0bb4f26431eaf385971d7eed SHA512 fbe09240a600abbcac952f52f05f28f9b305a1ae3def8b4144bd73bdb160acfbe5457086ef829057d5a73df1df5061668487b2ca5621df73628c8c4990b6b544 WHIRLPOOL 84d057c68b0fbf899594470e171f883b92def29f0f7f607b08d0d419dd01c5f2e0f6054f93387c32b6b7ffdd1ceb6e84ef6b8cfe5faaee1f89c2e8b10837dcb8
diff --git a/dev-haskell/bio/bio-0.5.3-r1.ebuild b/dev-haskell/bio/bio-0.5.3-r1.ebuild
new file mode 100644
index 00000000000..d723e7976b0
--- /dev/null
+++ b/dev-haskell/bio/bio-0.5.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="A bioinformatics library"
+HOMEPAGE="http://biohaskell.org/Libraries/Bio"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples test"
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parallel:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-haskell/quickcheck-2:2=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/tagsoup-0.8:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+
+ cabal_chdeps \
+ 'binary >=0.4 && <0.5' 'binary >=0.4 && <0.8'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ $(cabal_flag test test)
+}
+
+src_test() {
+ dist/build/qc/qc || die
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ use test && rm "${ED}"/usr/bin/qc
+ # many examples collide with dev-haskell/flower
+ if use examples ; then
+ pushd "${ED}"/usr/bin
+ local example
+ for example in *
+ do
+ mv "${example}" "${PN}-example-${example}"
+ done
+ popd
+ fi
+}
diff --git a/dev-haskell/bio/bio-0.5.3.ebuild b/dev-haskell/bio/bio-0.5.3.ebuild
new file mode 100644
index 00000000000..803e8b62713
--- /dev/null
+++ b/dev-haskell/bio/bio-0.5.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A bioinformatics library"
+HOMEPAGE="http://biohaskell.org/Libraries/Bio"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples test"
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parallel:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-haskell/quickcheck-2:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/tagsoup-0.8:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ cabal_chdeps \
+ 'binary >=0.4 && <0.5' 'binary >=0.4 && <0.8'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ $(cabal_flag test test)
+}
+
+src_test() {
+ dist/build/qc/qc || die
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ use test && rm "${ED}"/usr/bin/qc
+ # many examples collide with dev-haskell/flower
+ if use examples ; then
+ pushd "${ED}"/usr/bin
+ local example
+ for example in *
+ do
+ mv "${example}" "${PN}-example-${example}"
+ done
+ popd
+ fi
+}
diff --git a/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch b/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch
new file mode 100644
index 00000000000..d570d22917a
--- /dev/null
+++ b/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch
@@ -0,0 +1,7 @@
+diff --git a/Bio/Alignment/Bowtie.hs b/Bio/Alignment/Bowtie.hs
+index 883b057..3e58f0e 100644
+--- a/Bio/Alignment/Bowtie.hs
++++ b/Bio/Alignment/Bowtie.hs
+@@ -1 +1,2 @@
++{-# LANGUAGE FlexibleContexts #-}
+ {-| This module provides a data type to represent an alignment
diff --git a/dev-haskell/bio/metadata.xml b/dev-haskell/bio/metadata.xml
new file mode 100644
index 00000000000..c7052f42087
--- /dev/null
+++ b/dev-haskell/bio/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This is a collection of data structures and algorithms
+ useful for building bioinformatics-related tools
+ and utilities.
+
+ Current list of features includes: a Sequence data type supporting
+ protein and nucleotide sequences and conversion between them. As of version
+ 0.4, different kinds of sequence have different types. Support for quality
+ data, reading and writing Fasta formatted files, reading TwoBit and
+ phd formats, and Roche/454 SFF files. Rudimentary (i.e. unoptimized) support
+ for doing alignments - including dynamic adjustment of scores based on sequence quality.
+ Also Blast output parsing. Partly implemented single linkage clustering, and
+ multiple alignment. Reading Gene Ontology (GO) annotations (GOA) and
+ definitions\/hierarchy.
+
+ The Darcs repository is at: &lt;http://malde.org/~ketil/biohaskell/biolib&gt;.
+ </longdescription>
+</pkgmetadata>