summaryrefslogtreecommitdiff
path: root/dev-haskell/biosff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-09-27 19:40:04 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2015-09-27 19:40:15 +0100
commit1898ff1cd6f8f4ee056e1b7d4b75f398c97851e0 (patch)
tree976ffe1eeb3393115c96b168726f8cafcc71bffe /dev-haskell/biosff
parentcb016b47a33f6e6db7436df62b8fc9b43b794e81 (diff)
downloadgentoo-1898ff1cd6f8f4ee056e1b7d4b75f398c97851e0.tar.gz
gentoo-1898ff1cd6f8f4ee056e1b7d4b75f398c97851e0.tar.xz
dev-haskell/biosff: port to ghc-7.10, bug #561348
Bug: https://bugs.gentoo.org/561348 Reported-by: Toralf Förster Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-haskell/biosff')
-rw-r--r--dev-haskell/biosff/biosff-0.3.7.1.ebuild4
-rw-r--r--dev-haskell/biosff/files/biosff-0.3.7.1-ghc-7.10.patch7
2 files changed, 11 insertions, 0 deletions
diff --git a/dev-haskell/biosff/biosff-0.3.7.1.ebuild b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
index 0b7b3912f57..50d56c25578 100644
--- a/dev-haskell/biosff/biosff-0.3.7.1.ebuild
+++ b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
@@ -28,6 +28,10 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag fclip fclip) \
diff --git a/dev-haskell/biosff/files/biosff-0.3.7.1-ghc-7.10.patch b/dev-haskell/biosff/files/biosff-0.3.7.1-ghc-7.10.patch
new file mode 100644
index 00000000000..48c29358ca7
--- /dev/null
+++ b/dev-haskell/biosff/files/biosff-0.3.7.1-ghc-7.10.patch
@@ -0,0 +1,7 @@
+diff --git a/src/Flower/Main.hs b/src/Flower/Main.hs
+index b0cbd1c..3428db5 100644
+--- a/src/Flower/Main.hs
++++ b/src/Flower/Main.hs
+@@ -1 +1,2 @@
++{-# LANGUAGE FlexibleContexts #-}
+ -- FlowEr - FLOWgram ExtractoR