summaryrefslogtreecommitdiff
path: root/dev-haskell/cmdlib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cmdlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cmdlib')
-rw-r--r--dev-haskell/cmdlib/Manifest2
-rw-r--r--dev-haskell/cmdlib/cmdlib-0.3.5-r1.ebuild35
-rw-r--r--dev-haskell/cmdlib/cmdlib-0.3.5.ebuild27
-rw-r--r--dev-haskell/cmdlib/cmdlib-0.3.6.ebuild36
-rw-r--r--dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch16
-rw-r--r--dev-haskell/cmdlib/metadata.xml28
6 files changed, 144 insertions, 0 deletions
diff --git a/dev-haskell/cmdlib/Manifest b/dev-haskell/cmdlib/Manifest
new file mode 100644
index 00000000000..8c23faccb54
--- /dev/null
+++ b/dev-haskell/cmdlib/Manifest
@@ -0,0 +1,2 @@
+DIST cmdlib-0.3.5.tar.gz 22881 SHA256 b4f9d4e1d81a8776a6658e2b855b126c275f1e4c26d592d4dc9b134333712808 SHA512 29ca53ddde33d3154b57d56d80eed1e511476ffeb4e4b3722c003770d85d2c4815dccde9d25bc2c86dacad66af6ce6b924c2e97106945a9d9c8ed33fc2424d67 WHIRLPOOL 4c129f0d400f6654a2837380425061f36fd57ddeb73590f6ebcdfbfcfa014efe003682d23a020df60d66dcfe3a9a75bde11fbfa0d806e6fb59f097519b4f3351
+DIST cmdlib-0.3.6.tar.gz 22971 SHA256 5643d219c371f903c3f877b5955de4ca99a723bc96165f4f629d3e3dbc3fb357 SHA512 9d67e931c9caaaaf833215f2561d8ca6aeddd02c64b79343974d0a4d7f1dc618a7af4327ebf50d4071b871b1fd97edc3b5db5bbc8b3334352a20276733602024 WHIRLPOOL 8358c9ad496b48e8560d72cde4525fc4139cb5f2155a7d1a33241e3ad0de9a5093d24bb084cd14b11f78e423b393b13a30046b7df7a2669849fd19d36e5f8164
diff --git a/dev-haskell/cmdlib/cmdlib-0.3.5-r1.ebuild b/dev-haskell/cmdlib/cmdlib-0.3.5-r1.ebuild
new file mode 100644
index 00000000000..31a41d11259
--- /dev/null
+++ b/dev-haskell/cmdlib/cmdlib-0.3.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="a library for command line parsing & online help"
+HOMEPAGE="http://hackage.haskell.org/package/cmdlib"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+PATCHES=("${FILESDIR}/${PN}-0.3.4-ghc-6.12.patch")
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=mtl2 \
+ --flag=-test
+}
diff --git a/dev-haskell/cmdlib/cmdlib-0.3.5.ebuild b/dev-haskell/cmdlib/cmdlib-0.3.5.ebuild
new file mode 100644
index 00000000000..72a7968e9d8
--- /dev/null
+++ b/dev-haskell/cmdlib/cmdlib-0.3.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.13
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="a library for command line parsing & online help"
+HOMEPAGE="http://hackage.haskell.org/package/cmdlib"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl[profile?]
+ dev-haskell/split[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+PATCHES=("${FILESDIR}/${PN}-0.3.4-ghc-6.12.patch")
diff --git a/dev-haskell/cmdlib/cmdlib-0.3.6.ebuild b/dev-haskell/cmdlib/cmdlib-0.3.6.ebuild
new file mode 100644
index 00000000000..ae4b01cfe63
--- /dev/null
+++ b/dev-haskell/cmdlib/cmdlib-0.3.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -test,+mtl2
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="a library for command line parsing & online help"
+HOMEPAGE="http://hackage.haskell.org/package/cmdlib"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=mtl2 \
+ --flag=-test
+}
diff --git a/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch b/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch
new file mode 100644
index 00000000000..85a19d9aff0
--- /dev/null
+++ b/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch
@@ -0,0 +1,16 @@
+--- cmdlib-0.3.4-orig/System/Console/CmdLib/Command.hs 2011-10-07 07:19:48.000000000 +1100
++++ cmdlib-0.3.4/System/Console/CmdLib/Command.hs 2012-01-06 20:49:59.668959773 +1100
+@@ -225,6 +225,13 @@
+ commandGroup :: (Commands a) => String -> a -> [CommandWrap]
+ commandGroup s l = [CommandGroup s (toCommands l)]
+
++#if !MIN_VERSION_mtl(2,0,0)
++instance Monad (Either e) where
++ return = Right
++ Left l >>= _ = Left l
++ Right r >>= k = k r
++#endif
++
+ -- TODO: disambiguation, hidden commands (aliases)
+ findCommand :: String -> [CommandWrap] -> [CommandWrap]
+ findCommand key list = case accum list of Left x -> [x]
diff --git a/dev-haskell/cmdlib/metadata.xml b/dev-haskell/cmdlib/metadata.xml
new file mode 100644
index 00000000000..7c668045df5
--- /dev/null
+++ b/dev-haskell/cmdlib/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A commandline parsing library, based on getopt. Comes with a
+ powerful attribute system. Supports complex interfaces with many
+ options and commands, with option &amp; command grouping, with simple
+ and convenient API. Even though quite powerful, it strives to keep
+ simple things simple. The library uses &quot;System.Console.GetOpt&quot; as
+ its backend.
+
+ In comparison to the other commandline handling libraries:
+
+ Compared to cmdargs, cmdlib has a pure attribute system and is
+ based on GetOpt for help formatting &amp; argument parsing. Cmdlib may
+ also be more extendable due to typeclass design, and can use
+ user-supplied types for option arguments.
+
+ Cmdargs &gt;= 0.4 can optionally use a pure attribute system,
+ although this is clearly an add-on and the API is a second-class
+ citizen in relation to the impure version.
+
+ GetOpt and parseargs both require explicit flag representation, so
+ they live a level below cmdlib. GetOpt is in fact used as a
+ backend by cmdlib.
+ </longdescription>
+</pkgmetadata>