summaryrefslogtreecommitdiff
path: root/dev-haskell/connection
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/connection
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/connection')
-rw-r--r--dev-haskell/connection/Manifest1
-rw-r--r--dev-haskell/connection/connection-0.2.4.ebuild36
-rw-r--r--dev-haskell/connection/metadata.xml16
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/connection/Manifest b/dev-haskell/connection/Manifest
new file mode 100644
index 00000000000..6a92dd00383
--- /dev/null
+++ b/dev-haskell/connection/Manifest
@@ -0,0 +1 @@
+DIST connection-0.2.4.tar.gz 11067 SHA256 f2b82a91de6bdf9b76624335418013575d3e12ad2753c6e8997e2d016cdf806a SHA512 7a55f5bf8b35a8a03553051b38a01e3791e9c51db3222f5c91e77310cc9d61307e9d934d59e31f82be38804f1b9c60cd8856351b03e007e3b7a3c883abaabb48 WHIRLPOOL 2cc6c117a8d276a42e84233629d2e303f69e27ad4599fe69f1b04134724cb85c5f5efccd9f9fc4fb7cc1b00689e578c7eb665f6a67849ddbd83352b1e2812c9a
diff --git a/dev-haskell/connection/connection-0.2.4.ebuild b/dev-haskell/connection/connection-0.2.4.ebuild
new file mode 100644
index 00000000000..0355e3c472a
--- /dev/null
+++ b/dev-haskell/connection/connection-0.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple and easy network connections API"
+HOMEPAGE="http://github.com/vincenthz/hs-connection"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ dev-haskell/crypto-random:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ dev-haskell/securemem:=[profile?]
+ >=dev-haskell/socks-0.4:=[profile?]
+ >=dev-haskell/tls-1.2:=[profile?]
+ >=dev-haskell/x509-1.4:=[profile?]
+ >=dev-haskell/x509-store-1.4:=[profile?]
+ >=dev-haskell/x509-system-1.4:=[profile?]
+ >=dev-haskell/x509-validation-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/connection/metadata.xml b/dev-haskell/connection/metadata.xml
new file mode 100644
index 00000000000..5b691521f8b
--- /dev/null
+++ b/dev-haskell/connection/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Simple network library for all your connection need.
+
+ Features: Really simple to use, SSL/TLS, SOCKS.
+
+ This library provides a very simple api to create sockets
+ to a destination with the choice of SSL/TLS, and SOCKS.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-connection</remote-id>
+ </upstream>
+</pkgmetadata>