summaryrefslogtreecommitdiff
path: root/dev-haskell/criterion
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/criterion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/criterion')
-rw-r--r--dev-haskell/criterion/Manifest3
-rw-r--r--dev-haskell/criterion/criterion-0.8.1.0.ebuild37
-rw-r--r--dev-haskell/criterion/criterion-1.0.2.0.ebuild46
-rw-r--r--dev-haskell/criterion/criterion-1.1.0.0.ebuild46
-rw-r--r--dev-haskell/criterion/metadata.xml15
5 files changed, 147 insertions, 0 deletions
diff --git a/dev-haskell/criterion/Manifest b/dev-haskell/criterion/Manifest
new file mode 100644
index 00000000000..49bbc5b79b7
--- /dev/null
+++ b/dev-haskell/criterion/Manifest
@@ -0,0 +1,3 @@
+DIST criterion-0.8.1.0.tar.gz 155095 SHA256 ed8b5950afb9b4b73204226aea5659e1dbd7bd2682131fa56da4412e54b5f97b SHA512 96dd101dfcbb4cfea446235137d163e9bb806b8dbc6ca7cdb19f380dc8c6ad0169f22b08acb638c0e731be659b1f761cc4f3d33154c5cda3f44bf6f854b1b485 WHIRLPOOL c3ee52b6397eaef7126b96e47a56bdc80a0b56ad48f4c4f6780d9b958e56b2e84c6ea937fe61ee9b2c7d96579fc18be34a91fbbc7b0b2fde6540867bf22a1737
+DIST criterion-1.0.2.0.tar.gz 1003368 SHA256 1de2f6c9975135959fd8948ad2889310e5d19a736f9051a48c0fec081359ac0a SHA512 35063822e12bca0b8ad41d2e6fd2c6ddfd58432467d9fee7ca537e03fb0100dcf6c11565abd21c11c0736bc0e2c9977f248a559eec7c8b049c27ff54ea58f01a WHIRLPOOL e1496674e68972d973b192d2b2d050797f0afeefcca5c1e89699a9d0f6b934282f819fc084241ad8d7d9460ebdfca62d4f1a8deeded8ef3fb7040b59455a8836
+DIST criterion-1.1.0.0.tar.gz 1004534 SHA256 5cedd41bb6e5a85e65b51fdb00cb32038b826b8d18af072a8319cab43a452d38 SHA512 959635b49fbe9aeaffb8eb072e9998934732028311031debf5dc3bcbe7ea89ea3a330fe6656272888896ee9ee5e324d1ea72b25fbc0b5c466eb060d654ca61b6 WHIRLPOOL afdb569311f477b452b98d9788e4ba5348305d06392faf3f68f7299bba9d93ed524f1ed172c86a921bd5221b9d6e370cfc9630f5ab0552154f4e23d5f3622b68
diff --git a/dev-haskell/criterion/criterion-0.8.1.0.ebuild b/dev-haskell/criterion/criterion-0.8.1.0.ebuild
new file mode 100644
index 00000000000..22fd70deaa2
--- /dev/null
+++ b/dev-haskell/criterion/criterion-0.8.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Robust, reliable performance measurement and analysis"
+HOMEPAGE="https://github.com/bos/criterion"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.3.2.12:=[profile?]
+ >=dev-haskell/binary-0.6.3.0:=[profile?]
+ >=dev-haskell/glob-0.7.2:=[profile?]
+ >=dev-haskell/hastache-0.6.0:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-haskell/mwc-random-0.8.0.3:=[profile?]
+ >=dev-haskell/parsec-3.1.0:=[profile?]
+ >=dev-haskell/statistics-0.11:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/vector-0.7.1:=[profile?]
+ >=dev-haskell/vector-algorithms-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/criterion/criterion-1.0.2.0.ebuild b/dev-haskell/criterion/criterion-1.0.2.0.ebuild
new file mode 100644
index 00000000000..37429fc1d11
--- /dev/null
+++ b/dev-haskell/criterion/criterion-1.0.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Robust, reliable performance measurement and analysis"
+HOMEPAGE="http://www.serpentine.com/criterion"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?]
+ dev-haskell/ansi-wl-pprint:=[profile?]
+ >=dev-haskell/binary-0.5.1.0:=[profile?]
+ >=dev-haskell/cassava-0.3.0.0:=[profile?]
+ dev-haskell/either:=[profile?]
+ >=dev-haskell/glob-0.7.2:=[profile?]
+ >=dev-haskell/hastache-0.6.0:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-haskell/mwc-random-0.8.0.3:=[profile?]
+ >=dev-haskell/optparse-applicative-0.11:=[profile?]
+ >=dev-haskell/parsec-3.1.0:=[profile?]
+ >=dev-haskell/statistics-0.13.2.1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/vector-0.7.1:=[profile?]
+ >=dev-haskell/vector-algorithms-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.4
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"
diff --git a/dev-haskell/criterion/criterion-1.1.0.0.ebuild b/dev-haskell/criterion/criterion-1.1.0.0.ebuild
new file mode 100644
index 00000000000..f49169e043a
--- /dev/null
+++ b/dev-haskell/criterion/criterion-1.1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Robust, reliable performance measurement and analysis"
+HOMEPAGE="http://www.serpentine.com/criterion"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?]
+ >=dev-haskell/ansi-wl-pprint-0.6.7.2:=[profile?]
+ >=dev-haskell/binary-0.5.1.0:=[profile?]
+ >=dev-haskell/cassava-0.3.0.0:=[profile?]
+ >=dev-haskell/glob-0.7.2:=[profile?]
+ >=dev-haskell/hastache-0.6.0:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-haskell/mwc-random-0.8.0.3:=[profile?]
+ >=dev-haskell/optparse-applicative-0.11:=[profile?]
+ >=dev-haskell/parsec-3.1.0:=[profile?]
+ >=dev-haskell/statistics-0.13.2.1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/transformers-compat-0.4:=[profile?]
+ >=dev-haskell/vector-0.7.1:=[profile?]
+ >=dev-haskell/vector-algorithms-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.4
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"
diff --git a/dev-haskell/criterion/metadata.xml b/dev-haskell/criterion/metadata.xml
new file mode 100644
index 00000000000..4896e529809
--- /dev/null
+++ b/dev-haskell/criterion/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library provides a powerful but simple way to measure the
+ performance of Haskell code. It provides both a framework for
+ executing and analysing benchmarks and a set of driver functions
+ that makes it easy to build and run benchmarks, and to analyse their
+ results.
+
+ The fastest way to get started is to read the documentation and
+ examples in the Criterion.Main module.
+ </longdescription>
+</pkgmetadata>