summaryrefslogtreecommitdiff
path: root/dev-haskell/crypto-numbers
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/crypto-numbers
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/crypto-numbers')
-rw-r--r--dev-haskell/crypto-numbers/Manifest3
-rw-r--r--dev-haskell/crypto-numbers/crypto-numbers-0.2.1.ebuild33
-rw-r--r--dev-haskell/crypto-numbers/crypto-numbers-0.2.3.ebuild33
-rw-r--r--dev-haskell/crypto-numbers/crypto-numbers-0.2.7.ebuild37
-rw-r--r--dev-haskell/crypto-numbers/metadata.xml11
5 files changed, 117 insertions, 0 deletions
diff --git a/dev-haskell/crypto-numbers/Manifest b/dev-haskell/crypto-numbers/Manifest
new file mode 100644
index 00000000000..0f8a92681fa
--- /dev/null
+++ b/dev-haskell/crypto-numbers/Manifest
@@ -0,0 +1,3 @@
+DIST crypto-numbers-0.2.1.tar.gz 12247 SHA256 d8d6562f68968ed937f8041644713150f22ff780ff0d04f6b5a70710662782ad SHA512 dc370acd0eeb8f07704635aebb2645cf0154d748acf98093b9855defe8740ed4cbe0e4cfca9831f616a7ca8aa800642b48f6ab738302fd35c7f9ea269d382c97 WHIRLPOOL 48448ea77a28c324a6859c3c292c18afa8e62fe789bdfbda9815e75bfc1fa23341616487c90a85b2a5fbea012ced512c3d48aba7cc478e3895e2de0b53ffbf7f
+DIST crypto-numbers-0.2.3.tar.gz 15714 SHA256 f77dabd4dd6aa6343ba351b2ae1c55e4b9ef85c7911eadf6914704401cada25b SHA512 5ab8fdbcfb89f448148886fa7b31994452278da7d2ff8891702dddc861b6e3bdad432756fd639ba85534e1b6846b86a666f388bbae43d11a60a35d151cf1fa7e WHIRLPOOL 7127e25f6124d59edc17206ac05a9d29c1dd8832399525f64a6784dadceb1baadd8b1b083610072e181f7bca465eb5e27963777475488df9b379645895c46205
+DIST crypto-numbers-0.2.7.tar.gz 16064 SHA256 420aeb17e9cdcfdf8c950c6c6f10c54503c5524d36f611aa7238e3fd65f189a6 SHA512 4fac18f6d76d5cc9ae82d177a45c155847264494dd112db80a76c955faee4917b4b3c563bb76eb3a08923bb020138307a7115d78fe0caa20fd3fb2b12d679947 WHIRLPOOL e3d737267b93ee218e8b693e4bf458a8812244f0a910bbaf998b1711fe8c390907bce53abc425e33e150e916839662a25a036eaa349f632c740ec988f0dddb11
diff --git a/dev-haskell/crypto-numbers/crypto-numbers-0.2.1.ebuild b/dev-haskell/crypto-numbers/crypto-numbers-0.2.1.ebuild
new file mode 100644
index 00000000000..9d2f2115552
--- /dev/null
+++ b/dev-haskell/crypto-numbers/crypto-numbers-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cryptographic numbers: functions and algorithms"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-numbers"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/byteable
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/crypto-numbers/crypto-numbers-0.2.3.ebuild b/dev-haskell/crypto-numbers/crypto-numbers-0.2.3.ebuild
new file mode 100644
index 00000000000..a045e85313e
--- /dev/null
+++ b/dev-haskell/crypto-numbers/crypto-numbers-0.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cryptographic numbers: functions and algorithms"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-numbers"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/byteable
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/crypto-numbers/crypto-numbers-0.2.7.ebuild b/dev-haskell/crypto-numbers/crypto-numbers-0.2.7.ebuild
new file mode 100644
index 00000000000..cce2a3dd81b
--- /dev/null
+++ b/dev-haskell/crypto-numbers/crypto-numbers-0.2.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: integer-gmp:gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cryptographic numbers: functions and algorithms"
+HOMEPAGE="https://github.com/vincenthz/hs-crypto-numbers"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gmp"
+
+RDEPEND=">=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/byteable
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag gmp integer-gmp)
+}
diff --git a/dev-haskell/crypto-numbers/metadata.xml b/dev-haskell/crypto-numbers/metadata.xml
new file mode 100644
index 00000000000..7e70d3aeaed
--- /dev/null
+++ b/dev-haskell/crypto-numbers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Cryptographic numbers: functions and algorithms
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-numbers</remote-id>
+ </upstream>
+</pkgmetadata>