summaryrefslogtreecommitdiff
path: root/dev-haskell/edit-distance
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-05 23:08:56 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-05 23:23:06 +0000
commit3775ce0772742529048700ba510e07747bfb9bca (patch)
treeabc1dedae3ece9171cada35cff162bb4bdff5a0e /dev-haskell/edit-distance
parent2e7f9b8ac33817e3aba5b0fbd0b0bb29e740c33c (diff)
downloadgentoo-3775ce0772742529048700ba510e07747bfb9bca.tar.gz
gentoo-3775ce0772742529048700ba510e07747bfb9bca.tar.xz
dev-haskell/edit-distance: allow QuickCheck-2.9
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-haskell/edit-distance')
-rw-r--r--dev-haskell/edit-distance/edit-distance-0.2.2.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/edit-distance/edit-distance-0.2.2.1-r1.ebuild b/dev-haskell/edit-distance/edit-distance-0.2.2.1-r1.ebuild
new file mode 100644
index 00000000000..92a4eeedfa0
--- /dev/null
+++ b/dev-haskell/edit-distance/edit-distance-0.2.2.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Levenshtein and restricted Damerau-Levenshtein edit distances"
+HOMEPAGE="https://github.com/phadej/edit-distance"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-haskell/random-1.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.1.1
+ dev-haskell/test-framework-quickcheck2 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && <2.9' 'QuickCheck >= 2.4'
+}