summaryrefslogtreecommitdiff
path: root/dev-haskell/enumerator
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/enumerator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/enumerator')
-rw-r--r--dev-haskell/enumerator/Manifest1
-rw-r--r--dev-haskell/enumerator/enumerator-0.4.20.ebuild27
-rw-r--r--dev-haskell/enumerator/metadata.xml44
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-haskell/enumerator/Manifest b/dev-haskell/enumerator/Manifest
new file mode 100644
index 00000000000..376320d49b7
--- /dev/null
+++ b/dev-haskell/enumerator/Manifest
@@ -0,0 +1 @@
+DIST enumerator-0.4.20.tar.gz 53986 SHA256 33e21054352bb579e8db8697256ff3c61b3dc862c567f9e0fc2509f95e2b4709 SHA512 90711142b61cee2184420f4d5c9de9563afe6198cccbf5d9d8a75253b307c3df9fee388dc7770e8151f8d7b5570afdb30d8e4e597ce462302dda8430e64050ad WHIRLPOOL 46d388d8d04957fb5d8209e6bdeb9a4295a7261692092fe277050cc4d20bbb3abbbcdba5ce3f0b562e12697c6ec97bfa1c19a79ae1c4e9135b84e4d11980f67a
diff --git a/dev-haskell/enumerator/enumerator-0.4.20.ebuild b/dev-haskell/enumerator/enumerator-0.4.20.ebuild
new file mode 100644
index 00000000000..948e9d1fa89
--- /dev/null
+++ b/dev-haskell/enumerator/enumerator-0.4.20.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Reliable, high-performance processing with left-fold enumerators"
+HOMEPAGE="https://john-millikin.com/software/enumerator/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
diff --git a/dev-haskell/enumerator/metadata.xml b/dev-haskell/enumerator/metadata.xml
new file mode 100644
index 00000000000..94f1cc788ba
--- /dev/null
+++ b/dev-haskell/enumerator/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Typical buffer&amp;#x2013;based incremental I/O is based around a single loop,
+ which reads data from some source (such as a socket or file), transforms
+ it, and generates one or more outputs (such as a line count, HTTP
+ responses, or modified file). Although efficient and safe, these loops are
+ all single&amp;#x2013;purpose; it is difficult or impossible to compose
+ buffer&amp;#x2013;based processing loops.
+
+ Haskell&amp;#x2019;s concept of &amp;#x201C;lazy I/O&amp;#x201D; allows pure code to
+ operate on data from an external source. However, lazy I/O has several
+ shortcomings. Most notably, resources such as memory and file handles can
+ be retained for arbitrarily long periods of time, causing unpredictable
+ performance and error conditions.
+
+ Enumerators are an efficient, predictable, and safe alternative to lazy
+ I/O. Discovered by Oleg Kiselyov, they allow large datasets to be processed
+ in near&amp;#x2013;constant space by pure code. Although somewhat more complex
+ to write, using enumerators instead of lazy I/O produces more correct
+ programs.
+
+ This library contains an enumerator implementation for Haskell, designed to
+ be both simple and efficient. Three core types are defined, along with
+ numerous helper functions:
+
+ * /Iteratee/: Data sinks, analogous to left folds. Iteratees consume
+ a sequence of /input/ values, and generate a single /output/ value.
+ Many iteratees are designed to perform side effects (such as printing to
+ @stdout@), so they can also be used as monad transformers.
+
+ * /Enumerator/: Data sources, which generate input sequences. Typical
+ enumerators read from a file handle, socket, random number generator, or
+ other external stream. To operate, enumerators are passed an iteratee, and
+ provide that iteratee with input until either the iteratee has completed its
+ computation, or EOF.
+
+ * /Enumeratee/: Data transformers, which operate as both enumerators and
+ iteratees. Enumeratees read from an /outer/ enumerator, and provide the
+ transformed data to an /inner/ iteratee.
+ </longdescription>
+</pkgmetadata>