summaryrefslogtreecommitdiff
path: root/dev-haskell/ghc-paths
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/ghc-paths
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/ghc-paths')
-rw-r--r--dev-haskell/ghc-paths/Manifest1
-rw-r--r--dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild47
-rw-r--r--dev-haskell/ghc-paths/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/ghc-paths/Manifest b/dev-haskell/ghc-paths/Manifest
new file mode 100644
index 00000000000..6aae9dfd0e6
--- /dev/null
+++ b/dev-haskell/ghc-paths/Manifest
@@ -0,0 +1 @@
+DIST ghc-paths-0.1.0.9.tar.gz 2402 SHA256 afa68fb86123004c37c1dc354286af2d87a9dcfb12ddcb80e8bd0cd55bc87945 SHA512 0aa38add4a6f27ced115d769603f98eff6fe3e8b60a6477f4b1e669031cbb6408b87d2fed023d790169b623b9cb2b7983871a9bf9d5cfcc298774a34808e2094 WHIRLPOOL ace28459cefa96824343a3c774abdc2a1aa429dd23ef713eae9be664f0ce4cf9b71b1d0dce46594c3659d424ab7560461795bfd934238b61525255c8e2461c69
diff --git a/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild b/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild
new file mode 100644
index 00000000000..a2d16d58d7d
--- /dev/null
+++ b/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# haddock feature is explicitely disabled, as this library can be used as haddock depend
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="Knowledge of GHC's installation directories"
+HOMEPAGE="http://hackage.haskell.org/package/ghc-paths"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ # ghc-patch it has awfully unportable (across cabal versions) ghc detection code
+ # but in gentoo we install it to fixed patch, so remove Setup.hs detection code
+ cabal-mksetup
+
+ # and use gentoo's hardcoded one:
+ # a few things we need to replace, and example values
+ # GHC_PATHS_LIBDIR /usr/lib64/ghc-6.12.0.20091010
+ # GHC_PATHS_DOCDIR /usr/share/doc/ghc-6.12.0.20091010/html
+ # GHC_PATHS_GHC_PKG /usr/bin/ghc-pkg
+ # GHC_PATHS_GHC /usr/bin/ghc (be careful: GHC_PATHS_GHC is a substring of GHC_PATHS_GHC_PKG)
+
+ cat >"${S}/GHC/Paths.hs" <<-EOF
+ module GHC.Paths ( ghc, ghc_pkg, libdir, docdir ) where
+
+ libdir, docdir, ghc, ghc_pkg :: FilePath
+
+ libdir = "$(ghc-libdir)"
+ docdir = "/usr/share/doc/ghc-$(ghc-version)/html"
+
+ ghc = "$(ghc-getghc)"
+ ghc_pkg = "$(ghc-getghcpkg)"
+ EOF
+}
diff --git a/dev-haskell/ghc-paths/metadata.xml b/dev-haskell/ghc-paths/metadata.xml
new file mode 100644
index 00000000000..8c66906af53
--- /dev/null
+++ b/dev-haskell/ghc-paths/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>