summaryrefslogtreecommitdiff
path: root/dev-haskell/gnuidn
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/gnuidn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/gnuidn')
-rw-r--r--dev-haskell/gnuidn/Manifest2
-rw-r--r--dev-haskell/gnuidn/gnuidn-0.2.1.ebuild29
-rw-r--r--dev-haskell/gnuidn/gnuidn-0.2.ebuild26
-rw-r--r--dev-haskell/gnuidn/metadata.xml8
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-haskell/gnuidn/Manifest b/dev-haskell/gnuidn/Manifest
new file mode 100644
index 00000000000..c4b3699d01d
--- /dev/null
+++ b/dev-haskell/gnuidn/Manifest
@@ -0,0 +1,2 @@
+DIST gnuidn-0.2.1.tar.gz 16392 SHA256 67744c8559ed5c722c53c7a4c2a37821b59ede4b9288ceb995410ec6cb3031ca SHA512 f22ab90cf21b01c899ab61e231afefbb97f1f831a0dd8c32c405e381f3d3a01864c1208d0867d09e773e05d5a8a69d1f8303e35337ea51ce1277a47f9574e1ae WHIRLPOOL d1b7260905be95aa4611311570d3212d215d9c85b9e8290f6b0338583895896b26cd6ac2486e24f280929a6786889573bddd8496e8fcb8d69330e34cbf45db2f
+DIST gnuidn-0.2.tar.gz 16389 SHA256 edc77ef09aed85afac49f42c08c07fccde7211a9c7310996aa94d3f0c7156776 SHA512 df8a93169d187de905e096f26a3469bc86fcc304696782d3bdbfb76dea0119958d0365e3da77380c69f74029d3f1e652204b3edd315648f3fbef3e14b2fa6854 WHIRLPOOL 86bb909aaaf36e859e16369ce638b90129e7790a01d9a419c00b00669c1b691cc51f28c37292292621bcee1066498095c4f3f1a7e32a59d254230e57d91f07be
diff --git a/dev-haskell/gnuidn/gnuidn-0.2.1.ebuild b/dev-haskell/gnuidn/gnuidn-0.2.1.ebuild
new file mode 100644
index 00000000000..e89e737e4a6
--- /dev/null
+++ b/dev-haskell/gnuidn/gnuidn-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings for GNU IDN"
+HOMEPAGE="https://john-millikin.com/software/haskell-gnuidn/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ net-dns/libidn
+"
+DEPEND="${RDEPEND}
+ dev-haskell/c2hs
+ >=dev-haskell/cabal-1.6.0.3
+ virtual/pkgconfig
+"
diff --git a/dev-haskell/gnuidn/gnuidn-0.2.ebuild b/dev-haskell/gnuidn/gnuidn-0.2.ebuild
new file mode 100644
index 00000000000..e60ec0644d5
--- /dev/null
+++ b/dev-haskell/gnuidn/gnuidn-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings for GNU IDN"
+HOMEPAGE="http://john-millikin.com/software/bindings/gnuidn/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ net-dns/libidn"
+DEPEND="${RDEPEND}
+ dev-haskell/c2hs
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/gnuidn/metadata.xml b/dev-haskell/gnuidn/metadata.xml
new file mode 100644
index 00000000000..abd841c0b0e
--- /dev/null
+++ b/dev-haskell/gnuidn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Bindings for GNU IDN
+ </longdescription>
+</pkgmetadata>