summaryrefslogtreecommitdiff
path: root/dev-haskell/hdbc-mysql
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hdbc-mysql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hdbc-mysql')
-rw-r--r--dev-haskell/hdbc-mysql/Manifest1
-rw-r--r--dev-haskell/hdbc-mysql/files/hdbc-mysql-0.6.6.1-cabal-1.18.patch33
-rw-r--r--dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r1.ebuild30
-rw-r--r--dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild34
-rw-r--r--dev-haskell/hdbc-mysql/metadata.xml16
5 files changed, 114 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-mysql/Manifest b/dev-haskell/hdbc-mysql/Manifest
new file mode 100644
index 00000000000..a61bdad6928
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/Manifest
@@ -0,0 +1 @@
+DIST HDBC-mysql-0.6.6.1.tar.gz 23120 SHA256 35f1f32f20e9122800cde9eaf07d41e17b8786269f79125e31502cadacefa0e0 SHA512 be74be365021df54c9660af699cfec05271444da0042152c944d43927efcf7cf78712d3bfe25796f944af409b9eb24ab903c0b92bb6b3c6dbcf0a3ee057366bf WHIRLPOOL 274a15ab1f8b4dee2870c95319b6199803050087bd200540fe1f817ef5c0edae982398887f5c66e3da3accce671647e914c36e662ae9ca1122bc975ac92ba6a9
diff --git a/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.6.6.1-cabal-1.18.patch b/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.6.6.1-cabal-1.18.patch
new file mode 100644
index 00000000000..83ddd4a4c8c
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.6.6.1-cabal-1.18.patch
@@ -0,0 +1,33 @@
+--- HDBC-mysql-0.6.6.1-orig/Setup.lhs 2012-08-30 13:40:03.000000000 +1000
++++ HDBC-mysql-0.6.6.1/Setup.lhs 2014-07-03 22:31:21.162259637 +1000
+@@ -1,6 +1,7 @@
+ #!/usr/bin/env runhaskell
+
+ \begin{code}
++{-# LANGUAGE MultiParamTypeClasses, FlexibleInstances #-}
+ import Distribution.Simple
+ import Distribution.PackageDescription
+ import Distribution.Version
+@@ -26,8 +27,21 @@
+ }
+ }
+
++-- 'ConstOrId' is a @Cabal-1.16@ vs @Cabal-1.18@ compatibility hack,
++-- 'programFindLocation' has a new (unused in this case)
++-- parameter. 'ConstOrId' adds this parameter when types say it is
++-- mandatory.
++class ConstOrId a b where
++ constOrId :: a -> b
++
++instance ConstOrId a a where
++ constOrId = id
++
++instance ConstOrId a (b -> a) where
++ constOrId = const
++
+ mysqlConfigProgram = (simpleProgram "mysql_config") {
+- programFindLocation = \verbosity -> do
++ programFindLocation = \verbosity -> constOrId $ do
+ mysql_config <- findProgramOnPath "mysql_config" verbosity
+ mysql_config5 <- findProgramOnPath "mysql_config5" verbosity
+ return (mysql_config `mplus` mysql_config5)
diff --git a/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r1.ebuild b/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r1.ebuild
new file mode 100644
index 00000000000..153b74ffb1d
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-mysql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL driver for HDBC"
+HOMEPAGE="http://github.com/bos/hdbc-mysql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hdbc-2.1.0:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild b/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild
new file mode 100644
index 00000000000..2a9e21bd1c9
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_FEATURES+=" nocabaldep" # workaround depend on old cabal-1.16
+inherit base haskell-cabal
+
+MY_PN="HDBC-mysql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL driver for HDBC"
+HOMEPAGE="http://github.com/bos/hdbc-mysql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hdbc-2.1.0:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ virtual/mysql"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${PN}-0.6.6.1-cabal-1.18.patch")
diff --git a/dev-haskell/hdbc-mysql/metadata.xml b/dev-haskell/hdbc-mysql/metadata.xml
new file mode 100644
index 00000000000..e97aed95fc0
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides a MySQL driver for HDBC, implemented via
+ bindings to the C @mysqlclient@ library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bos/hdbc-mysql</remote-id>
+ </upstream>
+</pkgmetadata>