summaryrefslogtreecommitdiff
path: root/dev-haskell/http-client-conduit
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/http-client-conduit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/http-client-conduit')
-rw-r--r--dev-haskell/http-client-conduit/Manifest3
-rw-r--r--dev-haskell/http-client-conduit/http-client-conduit-0.2.0.0.ebuild29
-rw-r--r--dev-haskell/http-client-conduit/http-client-conduit-0.2.0.1.ebuild29
-rw-r--r--dev-haskell/http-client-conduit/http-client-conduit-0.3.0.ebuild26
-rw-r--r--dev-haskell/http-client-conduit/metadata.xml11
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-haskell/http-client-conduit/Manifest b/dev-haskell/http-client-conduit/Manifest
new file mode 100644
index 00000000000..a3cefb7d90b
--- /dev/null
+++ b/dev-haskell/http-client-conduit/Manifest
@@ -0,0 +1,3 @@
+DIST http-client-conduit-0.2.0.0.tar.gz 2098 SHA256 3ec0c89fc75d617ab3af17b77e5294fdac4b5c2cc7fc6c0b0ad1e1a26b3d64dd SHA512 e253a690379151fcb1b379eadc17969f1e28a67f9284d7b02ce396fca4abe4de5fd51ab041a8676742440583a1293a6498fd90a8a9d78b2e309e901e95d0382d WHIRLPOOL edea174f7db17512f1d362c718ac893767c01757aa509565e9100c6ea92fb4e6fcdc0b1ac24a8d513ecc7907a908106accb407ef995106635027e1857809fdbd
+DIST http-client-conduit-0.2.0.1.tar.gz 2104 SHA256 c54ac328bbc5583acaf36d073d9ab122f9e24db708bb2863ba75c303fbdcc93b SHA512 1fd691f613cf874ea6f596a1d178bee034aef48923d8665b33cb7519d49034c56198a1b98786f3b65e9b5fce36d7bea8e76bafd696c52f01a240da29a06696ab WHIRLPOOL a84c5465d3a3a19b5e20be1aff4d0920e216495c15beb7abe05d8658375269fd01c48c2d53b9f0570f000b6f625e30a8ca8c4f4eb81aa2e1397c718defbaf5a9
+DIST http-client-conduit-0.3.0.tar.gz 1176 SHA256 2934dd952999bdb87a0c1ccabfdaf985db82a12227cbaf358373b9797cc25b4c SHA512 c6d3a2ee7d2b3efca346835d226421bf18443d7248d743b0467b32a9697d845697267a5fa9ee5a7bdf2c6918c60f4f6897f3df109b9337ab3967b3b9ef2528fe WHIRLPOOL def62f2b4f7436d453105da215f243d2667e7b9fff6e688b8cb1557ea398365e4b8364445245fe6d4cb2f6e3a092a26d12c4b32623382e37a49ebe189c751d4b
diff --git a/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.0.ebuild b/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.0.ebuild
new file mode 100644
index 00000000000..c4b27b6950a
--- /dev/null
+++ b/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Frontend support for using http-client with conduit"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/conduit:=[profile?]
+ >=dev-haskell/http-client-0.2:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.1.ebuild b/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.1.ebuild
new file mode 100644
index 00000000000..960161b7008
--- /dev/null
+++ b/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Frontend support for using http-client with conduit"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/conduit:=[profile?]
+ >=dev-haskell/http-client-0.2:=[profile?]
+ >=dev-haskell/resourcet-0.4.6:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/http-client-conduit/http-client-conduit-0.3.0.ebuild b/dev-haskell/http-client-conduit/http-client-conduit-0.3.0.ebuild
new file mode 100644
index 00000000000..c50318caf0e
--- /dev/null
+++ b/dev-haskell/http-client-conduit/http-client-conduit-0.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile" # haddock hoogle hscolour" no files
+inherit haskell-cabal
+
+DESCRIPTION="Frontend support for using http-client with conduit (deprecated)"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/http-client-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/http-client-conduit/metadata.xml b/dev-haskell/http-client-conduit/metadata.xml
new file mode 100644
index 00000000000..6484303fe7c
--- /dev/null
+++ b/dev-haskell/http-client-conduit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Intended for use by higher-level libraries, such as http-conduit.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/http-client</remote-id>
+ </upstream>
+</pkgmetadata>