summaryrefslogtreecommitdiff
path: root/dev-haskell/http-conduit
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/http-conduit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/http-conduit')
-rw-r--r--dev-haskell/http-conduit/Manifest2
-rw-r--r--dev-haskell/http-conduit/http-conduit-1.9.5.1.ebuild60
-rw-r--r--dev-haskell/http-conduit/http-conduit-2.1.7.2.ebuild51
-rw-r--r--dev-haskell/http-conduit/metadata.xml8
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-haskell/http-conduit/Manifest b/dev-haskell/http-conduit/Manifest
new file mode 100644
index 00000000000..572d8428c11
--- /dev/null
+++ b/dev-haskell/http-conduit/Manifest
@@ -0,0 +1,2 @@
+DIST http-conduit-1.9.5.1.tar.gz 46601 SHA256 c2bd9c8bc5bb8f3de8b8c0c299d664db8e68a4bb24b658c768b6839b5cd1a3a8 SHA512 2e2ea0fbd15ed07de5e4b114ab67a68cfbbae9862cc78b9e4ae98bbd06a79e3bac1cedd246b148e6201359aa10a8ba5a6e8800d6ce1238530ba52ece3e135f00 WHIRLPOOL 96e8386157074d58f5492afe30020964b2a8a861be7fd0ece5d0c765058646ac1efb5ce5494fc42b885549374eac7134431508ad237523a5ebbe2d64aaf32978
+DIST http-conduit-2.1.7.2.tar.gz 23333 SHA256 ccd5d034d9c1f185ccf600e7f6d6153df793218233683ba073bab62d5449dc46 SHA512 020eae7a5846a880270b24d85ea4e7c2742c0f701e9e895b4dcaa1856f794fd00e09951e171104a173679d062789e5214ee24e0d63984e7d94d2cb2e5e7fb0ce WHIRLPOOL 10833001140438370ef01d3207562851c38339993f5d16d8c21a3c3c2627d94fbb0d38bccf2004a059ca2702d5567ca259cd9989cd0bf6776cb97073acd23652
diff --git a/dev-haskell/http-conduit/http-conduit-1.9.5.1.ebuild b/dev-haskell/http-conduit/http-conduit-1.9.5.1.ebuild
new file mode 100644
index 00000000000..acf63189031
--- /dev/null
+++ b/dev-haskell/http-conduit/http-conduit-1.9.5.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP client package with conduit interface and HTTPS support"
+HOMEPAGE="http://www.yesodweb.com/book/http-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-data-0.5.1:=[profile?]
+ >=dev-haskell/base64-bytestring-0.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1:=[profile?]
+ >=dev-haskell/blaze-builder-conduit-0.5:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ >=dev-haskell/certificate-1.3:=[profile?]
+ >=dev-haskell/conduit-0.5.5:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ >=dev-haskell/cookie-0.4:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/failure-0.1:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/mime-types-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/publicsuffixlist-0.0.3:=[profile?] <dev-haskell/publicsuffixlist-1.0:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/socks-0.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/tls-extra-0.5.0:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/transformers-base-0.4:=[profile?]
+ >=dev-haskell/utf8-string-0.3.4:=[profile?]
+ >=dev-haskell/void-0.5.5:=[profile?]
+ >=dev-haskell/zlib-conduit-0.5:=[profile?] <dev-haskell/zlib-conduit-1.1:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/cprng-aes-0.5.0:=[profile?]
+ >=dev-haskell/tls-1.1.3:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ >=dev-haskell/network-conduit-0.6
+ dev-haskell/wai
+ >=dev-haskell/warp-1.3.6 )
+"
diff --git a/dev-haskell/http-conduit/http-conduit-2.1.7.2.ebuild b/dev-haskell/http-conduit/http-conduit-2.1.7.2.ebuild
new file mode 100644
index 00000000000..376df156fb6
--- /dev/null
+++ b/dev-haskell/http-conduit/http-conduit-2.1.7.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP client package with conduit interface and HTTPS support"
+HOMEPAGE="http://www.yesodweb.com/book/http-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/conduit-0.5.5:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/http-client-0.4.3:=[profile?] <dev-haskell/http-client-0.5:=[profile?]
+ >=dev-haskell/http-client-tls-0.2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/blaze-builder
+ dev-haskell/case-insensitive
+ >=dev-haskell/conduit-1.1
+ dev-haskell/conduit-extra
+ >=dev-haskell/connection-0.2
+ dev-haskell/cookie
+ dev-haskell/data-default-class
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/network
+ dev-haskell/streaming-commons
+ dev-haskell/text
+ dev-haskell/utf8-string
+ >=dev-haskell/wai-3.0 <dev-haskell/wai-3.1
+ dev-haskell/wai-conduit
+ >=dev-haskell/warp-3.0.0.2 <dev-haskell/warp-3.2
+ dev-haskell/warp-tls )
+"
diff --git a/dev-haskell/http-conduit/metadata.xml b/dev-haskell/http-conduit/metadata.xml
new file mode 100644
index 00000000000..a39a0ef7b06
--- /dev/null
+++ b/dev-haskell/http-conduit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package uses attoparsec for parsing the actual contents of the HTTP connection. It also provides higher-level functions which allow you to avoid direct usage of conduits. See &lt;http://www.yesodweb.com/book/http-conduit&gt; for more information.
+ </longdescription>
+</pkgmetadata>