summaryrefslogtreecommitdiff
path: root/dev-haskell/lhs2tex
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/lhs2tex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/lhs2tex')
-rw-r--r--dev-haskell/lhs2tex/Manifest2
-rw-r--r--dev-haskell/lhs2tex/files/lhs2tex-1.18.1-mandir.patch11
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild34
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild28
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.19.ebuild34
-rw-r--r--dev-haskell/lhs2tex/metadata.xml6
6 files changed, 115 insertions, 0 deletions
diff --git a/dev-haskell/lhs2tex/Manifest b/dev-haskell/lhs2tex/Manifest
new file mode 100644
index 00000000000..a377751fa3f
--- /dev/null
+++ b/dev-haskell/lhs2tex/Manifest
@@ -0,0 +1,2 @@
+DIST lhs2tex-1.18.1.tar.gz 661053 SHA256 dccae22231a1db64cddc38b6f7ac98ac4d5677f03df2f548b2efe9a5e63e9648 SHA512 c44b4c5972b833ae41921d86e13c71ea60ac876a9996fb9a4e8d69ba25d000bbddb85f82d223b8a73381e3a4453c2757154a866fbbb48473f121dd88efb917d7 WHIRLPOOL 4d4473dc74f3951baf53fe35053cd3a1f922d2f25f700e43aab4957b01a5516208ed03ce1a13a1204d7a875293f586757b33dac852629b0854a1318c944905a9
+DIST lhs2tex-1.19.tar.gz 658353 SHA256 24ae0557d95673e0c6d9b0aca829181b734359880dd58802ac154b89f384b00e SHA512 63d4cb626c14dccc6e0989b358299078427d0c22ab726fd3d933bfef3b0d072a35113d132c87b61b7b8ac2c259c856e192d04e04d3eb744b958fc0df54c80abf WHIRLPOOL 4745d6d5229d1c8f3de2995aedc03ef6f19e9a32ef42d1be8f60ce568701839b4eb47a0bdf578e95d55dab34778fcc0b5ace7ef83b886f9aec25368823c22fe7
diff --git a/dev-haskell/lhs2tex/files/lhs2tex-1.18.1-mandir.patch b/dev-haskell/lhs2tex/files/lhs2tex-1.18.1-mandir.patch
new file mode 100644
index 00000000000..1a3c922723e
--- /dev/null
+++ b/dev-haskell/lhs2tex/files/lhs2tex-1.18.1-mandir.patch
@@ -0,0 +1,11 @@
+--- Setup.hs.orig 2014-11-03 00:57:44.033467328 +0530
++++ Setup.hs 2014-11-03 00:58:05.775218672 +0530
+@@ -205,7 +205,7 @@
+ else docdir (absoluteInstallDirs pd lbi cd) `joinFileName` "doc"
+ let manDir = if isWindows
+ then dataPref `joinFileName` "Documentation"
+- else datadir (absoluteInstallDirs pd lbi cd) `joinFileName` ".." `joinFileName` "man" `joinFileName` "man1"
++ else datadir (absoluteInstallDirs pd lbi cd) `joinFileName` ".." `joinFileName` ".." `joinFileName` "man" `joinFileName` "man1"
+ createDirectoryIfMissing True docDir
+ installOrdinaryFile v (lhs2texDocDir `joinFileName` "Guide2.pdf") (docDir `joinFileName` "Guide2.pdf")
+ when (not isWindows) $
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild
new file mode 100644
index 00000000000..9a8bbded77e
--- /dev/null
+++ b/dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="bin"
+inherit base haskell-cabal
+
+DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
+HOMEPAGE="http://www.andres-loeh.de/lhs2tex/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# dev-texlive/texlive-mathextra contains 'stmaryrd' font used
+# for guide generation
+RDEPEND=">=dev-tex/polytable-0.8.2
+ dev-texlive/texlive-mathextra"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ dev-haskell/mtl
+ dev-haskell/regex-compat
+ >=dev-lang/ghc-6.12.1"
+
+# Setup.hs uses 'Text.Regex' available in both 'r-c' and 'r-c-tdfa'
+HCFLAGS+=" -ignore-package=regex-compat-tdfa"
+
+# datadir is /usr/share/${PN}/${GHC_VER} so mandir is ${DATADIR}/../../man
+PATCHES=("${FILESDIR}/${PN}-1.18.1-mandir.patch")
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild
new file mode 100644
index 00000000000..407bb51fa8d
--- /dev/null
+++ b/dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
+HOMEPAGE="http://www.andres-loeh.de/lhs2tex/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# dev-texlive/texlive-mathextra contains 'stmaryrd' font used
+# for guide generation
+RDEPEND=">=dev-tex/polytable-0.8.2
+ dev-texlive/texlive-mathextra"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ dev-haskell/mtl
+ dev-haskell/regex-compat
+ >=dev-lang/ghc-6.12.1"
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.19.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.19.ebuild
new file mode 100644
index 00000000000..35a8eb1a86a
--- /dev/null
+++ b/dev-haskell/lhs2tex/lhs2tex-1.19.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="bin"
+inherit base haskell-cabal
+
+DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
+HOMEPAGE="http://www.andres-loeh.de/lhs2tex/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# dev-texlive/texlive-mathextra contains 'stmaryrd' font used
+# for guide generation
+RDEPEND=">=dev-tex/polytable-0.8.2
+ dev-texlive/texlive-mathextra"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ dev-haskell/mtl
+ dev-haskell/regex-compat
+ >=dev-lang/ghc-6.12.1"
+
+# Setup.hs uses 'Text.Regex' available in both 'r-c' and 'r-c-tdfa'
+HCFLAGS+=" -ignore-package=regex-compat-tdfa"
+
+# datadir is /usr/share/${PN}/${GHC_VER} so mandir is ${DATADIR}/../../man
+PATCHES=("${FILESDIR}/${PN}-1.18.1-mandir.patch")
diff --git a/dev-haskell/lhs2tex/metadata.xml b/dev-haskell/lhs2tex/metadata.xml
new file mode 100644
index 00000000000..66b9052a990
--- /dev/null
+++ b/dev-haskell/lhs2tex/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <herd>tex</herd>
+</pkgmetadata>