summaryrefslogtreecommitdiff
path: root/dev-haskell/list
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/list
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/list')
-rw-r--r--dev-haskell/list/Manifest2
-rw-r--r--dev-haskell/list/list-0.5.1.ebuild29
-rw-r--r--dev-haskell/list/list-0.5.2.ebuild31
-rw-r--r--dev-haskell/list/metadata.xml12
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-haskell/list/Manifest b/dev-haskell/list/Manifest
new file mode 100644
index 00000000000..2279582db5a
--- /dev/null
+++ b/dev-haskell/list/Manifest
@@ -0,0 +1,2 @@
+DIST List-0.5.1.tar.gz 6234 SHA256 3778f7695dbd2b75840724a1dea0430801d65242117df3815e6500281155f3c1 SHA512 af8907aa4521b6cbc0fa479e6a1a635fc0dac7135d74ffa9b1280e5962a40bf568f2a3b9145a9395e044bc4722edee886388c1167da7de4f70eaa1ccc6f465f0 WHIRLPOOL 7f3cd209513a380425c66d91bea739d511ce7b7611a89755addc171577c4daffe479b62b06e283665be9fb60b7e176b0f60a08cec46141cfaa6de19efe5140cb
+DIST List-0.5.2.tar.gz 6242 SHA256 27ddf9a9b348c3a2fc72ba8bed78ecacd32f26cc7ae1b8de8a066bd14ec8eaac SHA512 6bdeb8f8484b84ffc15ac933b37083dc2c76dc617242322a02ff20cbdbe44fc7201539bf3dae4d7afdcf899e625fff074e9df33b630ba1626419b6b8564817b2 WHIRLPOOL 49cf5363b9e7511b059e209f4f3c064983f8d06e9432a8803cc6f96341f79ad84bda5be19fc5201212d4494448da51a7b51709faf03eb64bcb12fab51232553d
diff --git a/dev-haskell/list/list-0.5.1.ebuild b/dev-haskell/list/list-0.5.1.ebuild
new file mode 100644
index 00000000000..55f7d4dc84b
--- /dev/null
+++ b/dev-haskell/list/list-0.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="List"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="List monad transformer and class"
+HOMEPAGE="http://github.com/yairchu/generator/tree"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/list/list-0.5.2.ebuild b/dev-haskell/list/list-0.5.2.ebuild
new file mode 100644
index 00000000000..ee4296617d1
--- /dev/null
+++ b/dev-haskell/list/list-0.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="List"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="List monad transformer and class"
+HOMEPAGE="http://github.com/yairchu/generator/tree"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/list/metadata.xml b/dev-haskell/list/metadata.xml
new file mode 100644
index 00000000000..451e7a22e3f
--- /dev/null
+++ b/dev-haskell/list/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A List monad transformer and a List class.
+ With standard list operations for Lists
+ </longdescription>
+ <upstream>
+ <remote-id type="github">yairchu/generator</remote-id>
+ </upstream>
+</pkgmetadata>