summaryrefslogtreecommitdiff
path: root/dev-haskell/maccatcher
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-10 22:52:18 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-11 09:48:03 +0100
commit9258396d5d62c288a3f75d15d7700cfa897f7e94 (patch)
treeccde1baa7a4971655ccadb51447d7d65492335d6 /dev-haskell/maccatcher
parent48d7f333894b9aaabcce761f5eb7bf0d9b26432f (diff)
downloadgentoo-9258396d5d62c288a3f75d15d7700cfa897f7e94.tar.gz
gentoo-9258396d5d62c288a3f75d15d7700cfa897f7e94.tar.xz
dev-haskell/maccatcher: update to EAPI=6
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-haskell/maccatcher')
-rw-r--r--dev-haskell/maccatcher/maccatcher-2.1.5-r1.ebuild34
-rw-r--r--dev-haskell/maccatcher/maccatcher-2.1.5.ebuild25
2 files changed, 34 insertions, 25 deletions
diff --git a/dev-haskell/maccatcher/maccatcher-2.1.5-r1.ebuild b/dev-haskell/maccatcher/maccatcher-2.1.5-r1.ebuild
new file mode 100644
index 00000000000..d098c9b6066
--- /dev/null
+++ b/dev-haskell/maccatcher/maccatcher-2.1.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+#hackport: flags: +split-base,+cli
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Obtain the host MAC address on *NIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/maccatcher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=cli \
+ --flag=split-base
+}
diff --git a/dev-haskell/maccatcher/maccatcher-2.1.5.ebuild b/dev-haskell/maccatcher/maccatcher-2.1.5.ebuild
deleted file mode 100644
index adee13f74fc..00000000000
--- a/dev-haskell/maccatcher/maccatcher-2.1.5.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# ebuild generated by hackport 0.2.13
-
-EAPI="3"
-
-CABAL_FEATURES="bin lib profile haddock hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Obtain the host MAC address on *NIX and Windows"
-HOMEPAGE="http://hackage.haskell.org/package/maccatcher"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/binary
- dev-haskell/parsec
- >=dev-lang/ghc-6.8.2"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"