summaryrefslogtreecommitdiff
path: root/dev-haskell/network-multicast
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/network-multicast
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/network-multicast')
-rw-r--r--dev-haskell/network-multicast/Manifest3
-rw-r--r--dev-haskell/network-multicast/metadata.xml9
-rw-r--r--dev-haskell/network-multicast/network-multicast-0.0.10.ebuild26
-rw-r--r--dev-haskell/network-multicast/network-multicast-0.0.11.ebuild26
-rw-r--r--dev-haskell/network-multicast/network-multicast-0.0.7.ebuild24
5 files changed, 88 insertions, 0 deletions
diff --git a/dev-haskell/network-multicast/Manifest b/dev-haskell/network-multicast/Manifest
new file mode 100644
index 00000000000..90a9a5b9576
--- /dev/null
+++ b/dev-haskell/network-multicast/Manifest
@@ -0,0 +1,3 @@
+DIST network-multicast-0.0.10.tar.gz 2975 SHA256 bd58901343d95a5905d323d90553c276b5c234a38c6927faf485e66ad4225b24 SHA512 2c08e4dbb09eb8ddd72e6c450ad729df5edf13fcc8fb72f7606bd05ea8206ec9e1809f7b8ce5677ced45ea33d03fd81678d697cff8e4f00521ca3500b51910f8 WHIRLPOOL 7f8f8c6b431aa6bda0007b0e87f6eb1bfc08e24f70c485c8afcc5c6ccdbe2faf106c5ca3256bd4cc871f17dccca24dd334e255bcb8e7b7277380fe78e9a4452f
+DIST network-multicast-0.0.11.tar.gz 2970 SHA256 65842175e53bb72164b7b1a448a3cc4bdf42df8d64089853ea54ccccd266fa39 SHA512 f38f4e683117412b97b602ddc324b17ffbb6c20f265086565b16124c15cb99ec63e4a21092cd33e87756d7c9ae15de8c63d8dd192503f7abfbbcf455f02796b2 WHIRLPOOL d1ee9602e7e414b6c82155287ec6193b2d5235b2446b43512dc9aa84f3787ad1acee0e05dec2aa18337cdb607c81ca47384f64e74ba438fdf42aa5af319b5c5a
+DIST network-multicast-0.0.7.tar.gz 2886 SHA256 8360edb6d575493331a92f03950e0039cad9ab09bf40bceaf821b2f3187914a3 SHA512 2bccdf9c8841aef256879291567c95b38419ce57a96900d9f63d9cd483e8a36be5523ed3b1604c5675d4109d7644911f890b9830ebb2c73dedec5731fc387f1c WHIRLPOOL be2208d1856544c65e561f252d6966f6dee7b154fd4ffae2dd59ab2059970a7c85cf546a0e5534c309017d1f431a654b78ad7f94b0ed3b70c7925fa7e77a48af
diff --git a/dev-haskell/network-multicast/metadata.xml b/dev-haskell/network-multicast/metadata.xml
new file mode 100644
index 00000000000..196bd199b64
--- /dev/null
+++ b/dev-haskell/network-multicast/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The &quot;Network.Multicast&quot; module is for sending
+ UDP datagrams over multicast (class D) addresses.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/network-multicast/network-multicast-0.0.10.ebuild b/dev-haskell/network-multicast/network-multicast-0.0.10.ebuild
new file mode 100644
index 00000000000..5dbd671576a
--- /dev/null
+++ b/dev-haskell/network-multicast/network-multicast-0.0.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple multicast library"
+HOMEPAGE="http://hackage.haskell.org/package/network-multicast"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
diff --git a/dev-haskell/network-multicast/network-multicast-0.0.11.ebuild b/dev-haskell/network-multicast/network-multicast-0.0.11.ebuild
new file mode 100644
index 00000000000..767221858d8
--- /dev/null
+++ b/dev-haskell/network-multicast/network-multicast-0.0.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple multicast library"
+HOMEPAGE="http://hackage.haskell.org/package/network-multicast"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/network-multicast/network-multicast-0.0.7.ebuild b/dev-haskell/network-multicast/network-multicast-0.0.7.ebuild
new file mode 100644
index 00000000000..4df47f5a701
--- /dev/null
+++ b/dev-haskell/network-multicast/network-multicast-0.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple multicast library"
+HOMEPAGE="http://hackage.haskell.org/package/network-multicast"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"