summaryrefslogtreecommitdiff
path: root/dev-haskell/nonce
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/nonce
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/nonce')
-rw-r--r--dev-haskell/nonce/Manifest1
-rw-r--r--dev-haskell/nonce/metadata.xml18
-rw-r--r--dev-haskell/nonce/nonce-1.0.2.ebuild30
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/nonce/Manifest b/dev-haskell/nonce/Manifest
new file mode 100644
index 00000000000..f5702768d51
--- /dev/null
+++ b/dev-haskell/nonce/Manifest
@@ -0,0 +1 @@
+DIST nonce-1.0.2.tar.gz 2872 SHA256 1004184996ea797b43189a0e73eab0b939f129cafc776341ca82289edb329cd0 SHA512 e47ed297c7aaa1ed98b6ce711cbc6653dbcbeba9b132750e588c9134f544e8b92b857f36a9331350711df14259dd0f54e49fa6e0da10e9334c5bf76952431894 WHIRLPOOL 1b2e463eae9802be025056627501abcf4a660da3749152faba1fea84a7ff35588f763e63974706edc145f4beef7c3a2ac11c4672247bf3531e2dc79ba8b81072
diff --git a/dev-haskell/nonce/metadata.xml b/dev-haskell/nonce/metadata.xml
new file mode 100644
index 00000000000..6436aa0cf42
--- /dev/null
+++ b/dev-haskell/nonce/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ According to the Wikipedia, a nonce is an arbitrary number used
+ only once in a cryptographic communication. This package
+ contain helper functions for generating nonces.
+
+ There are many kinds of nonces used in different situations.
+ It's not guaranteed that by using the nonces from this package
+ you won't have any security issues. Please make sure that the
+ nonces generated via this package are usable on your design.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">prowdsponsor/nonce</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/nonce/nonce-1.0.2.ebuild b/dev-haskell/nonce/nonce-1.0.2.ebuild
new file mode 100644
index 00000000000..0a40dbf8bdd
--- /dev/null
+++ b/dev-haskell/nonce/nonce-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generate cryptographic nonces"
+HOMEPAGE="https://github.com/prowdsponsor/nonce"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/cprng-aes-0.5:=[profile?] <dev-haskell/cprng-aes-0.7:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/text-0.9:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"