summaryrefslogtreecommitdiff
path: root/dev-haskell/patience
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/patience
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/patience')
-rw-r--r--dev-haskell/patience/Manifest1
-rw-r--r--dev-haskell/patience/metadata.xml18
-rw-r--r--dev-haskell/patience/patience-0.1.1.ebuild25
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/patience/Manifest b/dev-haskell/patience/Manifest
new file mode 100644
index 00000000000..e765af40dbc
--- /dev/null
+++ b/dev-haskell/patience/Manifest
@@ -0,0 +1 @@
+DIST patience-0.1.1.tar.gz 4610 SHA256 35c7c334d344b3cbdc61cc88c559bedb300ace860a80e3990aeb268f1f10db63 SHA512 dac94580d9b82023841b5406509f8cd0e58148756e4259708c21b78b480fb4fb67b21a82c81e702275f49d90bcd1d2b46d20bb96267131d4ff57334f110e14f7 WHIRLPOOL 4ed3f215213e4b20f23ae2601b2327a6c6221d0539baed0df4694b47c5226ee8db9c85b9c3f7101a7ba12f01b583ef009ac77cb20ad2946b8be986df76bfa65e
diff --git a/dev-haskell/patience/metadata.xml b/dev-haskell/patience/metadata.xml
new file mode 100644
index 00000000000..24a8de9e1c4
--- /dev/null
+++ b/dev-haskell/patience/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library implements the \&quot;patience diff\&quot; algorithm, as well as the patience
+ algorithm for the longest increasing subsequence problem.
+
+ Patience diff computes the difference between two lists, for example the
+ lines of two versions of a source file. It provides a good balance of
+ performance, nice output for humans, and implementation simplicity. For more
+ information, see &lt;http://alfedenzo.livejournal.com/170301.html&gt; and
+ &lt;http://bramcohen.livejournal.com/73318.html&gt;.
+
+ New in version 0.1.1: relaxed @containers@ dependency, so it should build on
+ GHC 6.10.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/patience/patience-0.1.1.ebuild b/dev-haskell/patience/patience-0.1.1.ebuild
new file mode 100644
index 00000000000..0887f2b0cc4
--- /dev/null
+++ b/dev-haskell/patience/patience-0.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Patience diff and longest increasing subsequence"
+HOMEPAGE="http://hackage.haskell.org/package/patience"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"