summaryrefslogtreecommitdiff
path: root/dev-haskell/profunctor-extras
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/profunctor-extras
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/profunctor-extras')
-rw-r--r--dev-haskell/profunctor-extras/Manifest2
-rw-r--r--dev-haskell/profunctor-extras/metadata.xml12
-rw-r--r--dev-haskell/profunctor-extras/profunctor-extras-3.3.3.1.ebuild30
-rw-r--r--dev-haskell/profunctor-extras/profunctor-extras-4.0.ebuild26
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-haskell/profunctor-extras/Manifest b/dev-haskell/profunctor-extras/Manifest
new file mode 100644
index 00000000000..8cf9000a25f
--- /dev/null
+++ b/dev-haskell/profunctor-extras/Manifest
@@ -0,0 +1,2 @@
+DIST profunctor-extras-3.3.3.1.tar.gz 6493 SHA256 efc081346254de99b18418696510b255dd0c74628c3abe1174c6f3a7a751ca9a SHA512 78dc345cf1c7be7846d9c39775c6f0e71251a447461180e54239f406f8583524cf034139e57ca3d9054461c103432220c50f7c2f21403b4f5e3f4878b55788d8 WHIRLPOOL 922834f9b13874ac4d89bf32fbf9950153a266130848e4f30e48abdbf3d81abf1282b5406f55afe8eb91cd670abc34cd5175af6ba73494e1c6800a5891494b86
+DIST profunctor-extras-4.0.tar.gz 2588 SHA256 8a3c51ef41d686e39f87875dd48e72e5aa83956125bdf9922edf531c292a4482 SHA512 0bf2000b18ccc5d85be28d48199f1e64c6fc8813b0e08b9e1c7bab756ebfe432c3e3c1e2ae87da81e54b1dac183776348a80f089f595ff318f9447d75ff7e358 WHIRLPOOL dc8b15c1a14942791f09a20e279687d442fbf4a9f319e03f83093d9649f1e71d1573e2c10929a34e231df95528e52a312eab549cc1e66f2e67bce432831c5c78
diff --git a/dev-haskell/profunctor-extras/metadata.xml b/dev-haskell/profunctor-extras/metadata.xml
new file mode 100644
index 00000000000..3d3c7c63172
--- /dev/null
+++ b/dev-haskell/profunctor-extras/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package provides a number of utilities and constructions that arise
+ when working with profunctors that require minor extensions to Haskell 98.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ekmett/profunctor-extras</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/profunctor-extras/profunctor-extras-3.3.3.1.ebuild b/dev-haskell/profunctor-extras/profunctor-extras-3.3.3.1.ebuild
new file mode 100644
index 00000000000..3bf996028da
--- /dev/null
+++ b/dev-haskell/profunctor-extras/profunctor-extras-3.3.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Profunctor extras"
+HOMEPAGE="http://github.com/ekmett/profunctor-extras/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/comonad-3:=[profile?]
+ >=dev-haskell/profunctors-3.2:=[profile?]
+ >=dev-haskell/semigroupoid-extras-3:=[profile?]
+ >=dev-haskell/semigroupoids-3:=[profile?]
+ >=dev-haskell/tagged-0.4.4:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/profunctor-extras/profunctor-extras-4.0.ebuild b/dev-haskell/profunctor-extras/profunctor-extras-4.0.ebuild
new file mode 100644
index 00000000000..00ad4835613
--- /dev/null
+++ b/dev-haskell/profunctor-extras/profunctor-extras-4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="This package has been absorbed into profunctors 4.0"
+HOMEPAGE="http://github.com/ekmett/profunctor-extras/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/profunctors-4:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"