summaryrefslogtreecommitdiff
path: root/dev-haskell/psqueue
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/psqueue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/psqueue')
-rw-r--r--dev-haskell/psqueue/Manifest1
-rw-r--r--dev-haskell/psqueue/metadata.xml14
-rw-r--r--dev-haskell/psqueue/psqueue-1.1-r1.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/psqueue/Manifest b/dev-haskell/psqueue/Manifest
new file mode 100644
index 00000000000..44733f4ba3c
--- /dev/null
+++ b/dev-haskell/psqueue/Manifest
@@ -0,0 +1 @@
+DIST PSQueue-1.1.tar.gz 6280 SHA256 a8e0871ad10f916f55c3b9baec53eff23c4e97e09cf96d6c66771789e00a49cc SHA512 34fbd599b7fc47aef8952db79c848f4b50716d2d900b1d8274733ad4c7382d41a0407159e89af9828355c618412c626e4384f2e7461396b51cf866d9b8cfdb0d WHIRLPOOL 901cc5a70b02b4b09f1cc716e672c023c00661dd8d99160478d9aa2f00b066d4e2895697acaa11909cd4f9316b416d29bc19b9c5287377cba38f0290ff8e5af7
diff --git a/dev-haskell/psqueue/metadata.xml b/dev-haskell/psqueue/metadata.xml
new file mode 100644
index 00000000000..1c09f17286f
--- /dev/null
+++ b/dev-haskell/psqueue/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A /priority search queue/ efficiently supports the
+ opperations of both a search tree and a priority queue. A
+ &#39;Binding&#39; is a product of a key and a priority. Bindings
+ can be inserted, deleted, modified and queried in
+ logarithmic time, and the binding with the least priority
+ can be retrieved in constant time. A queue can be built
+ from a list of bindings, sorted by keys, in linear time.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/psqueue/psqueue-1.1-r1.ebuild b/dev-haskell/psqueue/psqueue-1.1-r1.ebuild
new file mode 100644
index 00000000000..9e01e521fbc
--- /dev/null
+++ b/dev-haskell/psqueue/psqueue-1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="PSQueue"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Priority Search Queue"
+HOMEPAGE="http://hackage.haskell.org/package/PSQueue"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"