summaryrefslogtreecommitdiff
path: root/dev-haskell/regex-pcre
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/regex-pcre
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/regex-pcre')
-rw-r--r--dev-haskell/regex-pcre/Manifest1
-rw-r--r--dev-haskell/regex-pcre/metadata.xml8
-rw-r--r--dev-haskell/regex-pcre/regex-pcre-0.94.4-r1.ebuild34
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/regex-pcre/Manifest b/dev-haskell/regex-pcre/Manifest
new file mode 100644
index 00000000000..a82034b36b8
--- /dev/null
+++ b/dev-haskell/regex-pcre/Manifest
@@ -0,0 +1 @@
+DIST regex-pcre-0.94.4.tar.gz 10814 SHA256 8eaa7d4ac6c0a4ba35aa59fc3f6b8f8e252bb25a47e136791446a74752e226c0 SHA512 b14db2fb88f9a70b60cfac0ecc242554929d03982b7ffef18e36a2a8ddbef3bbc3f7f1ccb549aa805aec43f30b3ca22856d2e4315dba15e9c22ed34638dba92e WHIRLPOOL 65dd666427cec560c24b7551b4bd19a613b14155ceaf250e28abbf3b016dfcede3ced7557ea516d4006662b7e19c65ec41c66f9f7bf77737fd8454dec0f55f76
diff --git a/dev-haskell/regex-pcre/metadata.xml b/dev-haskell/regex-pcre/metadata.xml
new file mode 100644
index 00000000000..9f3073bcbd9
--- /dev/null
+++ b/dev-haskell/regex-pcre/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The PCRE backend to accompany regex-base, see www.pcre.org
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/regex-pcre/regex-pcre-0.94.4-r1.ebuild b/dev-haskell/regex-pcre/regex-pcre-0.94.4-r1.ebuild
new file mode 100644
index 00000000000..d68c7e1604d
--- /dev/null
+++ b/dev-haskell/regex-pcre/regex-pcre-0.94.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: +newbase,+splitbase
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Replaces/Enhances Text.Regex"
+HOMEPAGE="http://hackage.haskell.org/package/regex-pcre"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/regex-base-0.93:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ dev-libs/libpcre
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=newbase \
+ --flag=splitbase
+}