summaryrefslogtreecommitdiff
path: root/dev-haskell/simple-reflect
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/simple-reflect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/simple-reflect')
-rw-r--r--dev-haskell/simple-reflect/Manifest2
-rw-r--r--dev-haskell/simple-reflect/metadata.xml11
-rw-r--r--dev-haskell/simple-reflect/simple-reflect-0.3.1.ebuild23
-rw-r--r--dev-haskell/simple-reflect/simple-reflect-0.3.2.ebuild25
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/simple-reflect/Manifest b/dev-haskell/simple-reflect/Manifest
new file mode 100644
index 00000000000..9694fdedcbc
--- /dev/null
+++ b/dev-haskell/simple-reflect/Manifest
@@ -0,0 +1,2 @@
+DIST simple-reflect-0.3.1.tar.gz 4286 SHA256 daf0d8cdc82011b5b97077939507101611c0a6008543832ba07c2131dd6137a1 SHA512 bb6a7a10d385efec23fff6252acf7b09e00a8e1de97675dfd7cd1ebe765e7b91418452ef9d62454d6a01ede0a10a9ae8e4ba68b7409ac772d46224458bfcb760 WHIRLPOOL 750a268b0dc34e8dc8c2a5f53ae9050728b428c9618ef0859a2ffb443525a497ee3929ea937f63a1dd2219b53aa8d6097d5d95cb54fcefbb7629ea00b9d4c3e2
+DIST simple-reflect-0.3.2.tar.gz 4492 SHA256 38224eb3d0d5eafc7101ad48fa92001c3e753a015d53bb12753a3836b871ecb6 SHA512 0e8e9666b10fcebbb4fe421ca8a1102d2028d8a4b2b9c196400b15ceedaa0420160e1536fadf55fdc316e1a07fb11aa92e2933b2fe491d27a1f3c54b62f268a1 WHIRLPOOL 5692e7a262636e1f52d0d73ed98b320eaeb5c2ee8a84212f6a8b5ba009f7cecf4d64d1d972668d071f67ceb5e2349885c3b6729bd6a4d97bda6b7baead7bbf3d
diff --git a/dev-haskell/simple-reflect/metadata.xml b/dev-haskell/simple-reflect/metadata.xml
new file mode 100644
index 00000000000..71a0501f1cb
--- /dev/null
+++ b/dev-haskell/simple-reflect/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package allows simple reflection of expressions containing variables.
+ Reflection here means that a Haskell expression is turned into a string.
+ The primary aim of this package is teaching and understanding;
+ there are no options for manipulating the reflected expressions beyond showing them.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/simple-reflect/simple-reflect-0.3.1.ebuild b/dev-haskell/simple-reflect/simple-reflect-0.3.1.ebuild
new file mode 100644
index 00000000000..228502065c0
--- /dev/null
+++ b/dev-haskell/simple-reflect/simple-reflect-0.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple reflection of expressions containing variables"
+HOMEPAGE="http://twan.home.fmf.nl/blog/haskell/simple-reflection-of-expressions.details"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/simple-reflect/simple-reflect-0.3.2.ebuild b/dev-haskell/simple-reflect/simple-reflect-0.3.2.ebuild
new file mode 100644
index 00000000000..7e98431e0cb
--- /dev/null
+++ b/dev-haskell/simple-reflect/simple-reflect-0.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple reflection of expressions containing variables"
+HOMEPAGE="http://twanvl.nl/blog/haskell/simple-reflection-of-expressions"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"