summaryrefslogtreecommitdiff
path: root/dev-haskell/simple-sendfile/simple-sendfile-0.2.25.ebuild
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-06 11:38:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-06 12:02:56 +0000
commit97bd437eeafff3e36c862f7a94df733f9604ce2f (patch)
tree8b498e8ce728b5af88aa59267099d0e4547bb236 /dev-haskell/simple-sendfile/simple-sendfile-0.2.25.ebuild
parent4ff501d7405f43f12f3c0a5a87739ee796d1edf7 (diff)
downloadgentoo-97bd437eeafff3e36c862f7a94df733f9604ce2f.tar.gz
gentoo-97bd437eeafff3e36c862f7a94df733f9604ce2f.tar.xz
dev-haskell/simple-sendfile: bump up to 0.2.25
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-haskell/simple-sendfile/simple-sendfile-0.2.25.ebuild')
-rw-r--r--dev-haskell/simple-sendfile/simple-sendfile-0.2.25.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/simple-sendfile/simple-sendfile-0.2.25.ebuild b/dev-haskell/simple-sendfile/simple-sendfile-0.2.25.ebuild
new file mode 100644
index 00000000000..de378ae1558
--- /dev/null
+++ b/dev-haskell/simple-sendfile/simple-sendfile-0.2.25.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cross platform library for the sendfile system call"
+HOMEPAGE="http://hackage.haskell.org/package/simple-sendfile"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+allow-bsd"
+
+RDEPEND="dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/conduit
+ dev-haskell/conduit-extra
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/resourcet )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag allow-bsd allow-bsd)
+}