summaryrefslogtreecommitdiff
path: root/dev-haskell/socks
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/socks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/socks')
-rw-r--r--dev-haskell/socks/Manifest2
-rw-r--r--dev-haskell/socks/metadata.xml11
-rw-r--r--dev-haskell/socks/socks-0.5.3.ebuild27
-rw-r--r--dev-haskell/socks/socks-0.5.4.ebuild27
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-haskell/socks/Manifest b/dev-haskell/socks/Manifest
new file mode 100644
index 00000000000..8e8a1f3ab6b
--- /dev/null
+++ b/dev-haskell/socks/Manifest
@@ -0,0 +1,2 @@
+DIST socks-0.5.3.tar.gz 8015 SHA256 9d7865d2bf9082c32de15c1791241b3e8b8435706bed41bbe24ad2bc0f5d5231 SHA512 84dbf702741f6ed486f165e1d14ecf82c877a578a5c00f35cf8f303caf3fb3921d7ea9912f07e357811e1a884e50d058c21080c9cfeec6f5f0499058852c51bf WHIRLPOOL bda68d693d4e71401a2b9e9add5487b199319026611e750baf47cb45fc938ab22a5f3bd847a603df041a7a5af3936aa4b94f2a087417e8c3632f03212376783a
+DIST socks-0.5.4.tar.gz 8021 SHA256 e9b5e1ea78592632bb086e5f4d6da523be01921a4a8998ca78552bdc396db4da SHA512 eba119e40e521f963ed779f8247832bd54db7c57267f433b89a57f72395eb212231d51fb5c56bb910185bc273aaee1044999fa781ad31da56e6d0ec03f07e783 WHIRLPOOL 68c1eaf52dcb0256abbc023a9a0ee81e85ce2b22912c67c7d1ba52a4d404f64fa8757deaa438e1736054b1479b5adbfd74adce7b227214d0bfa1c05f0c4eb571
diff --git a/dev-haskell/socks/metadata.xml b/dev-haskell/socks/metadata.xml
new file mode 100644
index 00000000000..9640b4f0632
--- /dev/null
+++ b/dev-haskell/socks/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Socks proxy (version 5) implementation.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-socks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/socks/socks-0.5.3.ebuild b/dev-haskell/socks/socks-0.5.3.ebuild
new file mode 100644
index 00000000000..92c8102d298
--- /dev/null
+++ b/dev-haskell/socks/socks-0.5.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Socks proxy (version 5) implementation"
+HOMEPAGE="http://github.com/vincenthz/hs-socks"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.3.1:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
diff --git a/dev-haskell/socks/socks-0.5.4.ebuild b/dev-haskell/socks/socks-0.5.4.ebuild
new file mode 100644
index 00000000000..92c8102d298
--- /dev/null
+++ b/dev-haskell/socks/socks-0.5.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Socks proxy (version 5) implementation"
+HOMEPAGE="http://github.com/vincenthz/hs-socks"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.3.1:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"