summaryrefslogtreecommitdiff
path: root/dev-haskell/testpack
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-22 23:09:24 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-22 23:10:57 +0000
commitc9784dc6bf642e0da6d3a0815811bdf530bb6dba (patch)
tree7d172d3acce6ac1e3f8bae1f12f88178fa283a70 /dev-haskell/testpack
parent46fa9a3fbb5f9727a44ac42c5ac6e82725446e3e (diff)
downloadgentoo-c9784dc6bf642e0da6d3a0815811bdf530bb6dba.tar.gz
gentoo-c9784dc6bf642e0da6d3a0815811bdf530bb6dba.tar.xz
dev-haskell/testpack: tweak for QC-2.8.2
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-haskell/testpack')
-rw-r--r--dev-haskell/testpack/files/testpack-2.1.3.0-QC-2.8.2.patch12
-rw-r--r--dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild1
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-haskell/testpack/files/testpack-2.1.3.0-QC-2.8.2.patch b/dev-haskell/testpack/files/testpack-2.1.3.0-QC-2.8.2.patch
new file mode 100644
index 00000000000..9ea5f8dfe4d
--- /dev/null
+++ b/dev-haskell/testpack/files/testpack-2.1.3.0-QC-2.8.2.patch
@@ -0,0 +1,12 @@
+diff --git a/src/Test/QuickCheck/Instances.hs b/src/Test/QuickCheck/Instances.hs
+index 98367b7..f65eb37 100644
+--- a/src/Test/QuickCheck/Instances.hs
++++ b/src/Test/QuickCheck/Instances.hs
+@@ -30,2 +30,3 @@ import Data.Word
+
++#if ! MIN_VERSION_QuickCheck(2,8,2)
+ instance (Arbitrary k, Arbitrary v, Eq k, Ord k) => Arbitrary (Map.Map k v) where
+@@ -37,2 +38,3 @@ instance (CoArbitrary k, CoArbitrary v, Eq k, Ord k) => CoArbitrary (Map.Map k v
+ coarbitrary = coarbitrary . Map.keys
++#endif
+
diff --git a/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild b/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
index 7168eb3b0ec..d5f79b55c41 100644
--- a/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
+++ b/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
@@ -31,4 +31,5 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-qc28.patch
epatch "${FILESDIR}"/${P}-HUnit-1.3.patch
+ epatch "${FILESDIR}"/${P}-QC-2.8.2.patch
}