summaryrefslogtreecommitdiff
path: root/dev-haskell/text-stream-decode
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/text-stream-decode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/text-stream-decode')
-rw-r--r--dev-haskell/text-stream-decode/Manifest1
-rw-r--r--dev-haskell/text-stream-decode/metadata.xml11
-rw-r--r--dev-haskell/text-stream-decode/text-stream-decode-0.1.0.5.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/text-stream-decode/Manifest b/dev-haskell/text-stream-decode/Manifest
new file mode 100644
index 00000000000..96d7d7ca52a
--- /dev/null
+++ b/dev-haskell/text-stream-decode/Manifest
@@ -0,0 +1 @@
+DIST text-stream-decode-0.1.0.5.tar.gz 12335 SHA256 fede45dc702b29ca3e25591df7f43244aa1a6ef99bb8bbc2e33aa35934b354e8 SHA512 9005cc7013f56809cb0a86fa57aa6bbe97936095d100e35d86ae7e9013e0bbcced3f5522da08f5fe76585fda1e8f55b364a1ad787f9c7c7be30fae6555083a5d WHIRLPOOL d36f74c5c0baacba4f4fa11e1e2dc042bc6d4e416873993fe099ecf0bcfe7234e9abd3ab88226b7c461ad5f6c23c88a7a58f76a7b09390deea3d9b4ce91c8bd6
diff --git a/dev-haskell/text-stream-decode/metadata.xml b/dev-haskell/text-stream-decode/metadata.xml
new file mode 100644
index 00000000000..d76328ffa81
--- /dev/null
+++ b/dev-haskell/text-stream-decode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The @text@ package provides high performance functions for decoding strict and lazy @ByteString@s into @Text@. However, these functions present two issues for streaming data libraries: they throw exceptions from pure code, and are not designed for incremental consumption. This library addresses both issues with a unified API for UTF-8, -16LE, -16BE, -32LE, and -32BE. It is intended for use by high level streaming data libraries, such as conduit, enumerator, iteratee, and pipes.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">fpco/text-stream-decode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/text-stream-decode/text-stream-decode-0.1.0.5.ebuild b/dev-haskell/text-stream-decode/text-stream-decode-0.1.0.5.ebuild
new file mode 100644
index 00000000000..afe3336d7c4
--- /dev/null
+++ b/dev-haskell/text-stream-decode/text-stream-decode-0.1.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: +text11
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming decoding functions for UTF encodings. (deprecated)"
+HOMEPAGE="http://github.com/fpco/text-stream-decode"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.8 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=text11
+}