summaryrefslogtreecommitdiff
path: root/dev-haskell/uniqueid
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/uniqueid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/uniqueid')
-rw-r--r--dev-haskell/uniqueid/Manifest1
-rw-r--r--dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch46
-rw-r--r--dev-haskell/uniqueid/metadata.xml15
-rw-r--r--dev-haskell/uniqueid/uniqueid-0.1.1.ebuild27
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-haskell/uniqueid/Manifest b/dev-haskell/uniqueid/Manifest
new file mode 100644
index 00000000000..db318ce350c
--- /dev/null
+++ b/dev-haskell/uniqueid/Manifest
@@ -0,0 +1 @@
+DIST uniqueid-0.1.1.tar.gz 2779 SHA256 e69df591c1ab9901af24bf0e63032765eb2b1ba4ca4fb720a234e9f292e03268 SHA512 4a1f753a320a5ddae8dd47c3e3729144cf28effaaa6f16a8cf13ad614e4aba3f720f82025f86d7c04ae5c28d03825b4d3442caa01cd534dfa05a70c6c9cadc68 WHIRLPOOL 4470eec443ae506ab61e5755bab93ac1b0da1d634cea06cc9e255c6575a80e0c4de569e3ec178bbe9602694ea111707fd482fd66d37721529b7417f221570172
diff --git a/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch b/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch
new file mode 100644
index 00000000000..a48815ecda0
--- /dev/null
+++ b/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch
@@ -0,0 +1,46 @@
+diff --git a/Data/Unique/Id.hs b/Data/Unique/Id.hs
+index f41127e..56853d9 100644
+--- a/Data/Unique/Id.hs
++++ b/Data/Unique/Id.hs
+@@ -14,7 +14,7 @@ module Data.Unique.Id (
+ ) where
+
+ import GHC.Exts
+-import GHC.IOBase ( unsafeDupableInterleaveIO )
++import GHC.IO ( unsafeDupableInterleaveIO )
+
+ import Data.IORef
+ import System.IO.Unsafe ( unsafePerformIO )
+@@ -55,15 +55,15 @@ splitIdSupplyL ids = ids1 : splitIdSupplyL ids2
+ idFromSupply :: IdSupply -> Id
+ idFromSupply (IdSupply n _ _) = Id (I# n)
+
+-instance Eq Id where Id (I# x) == Id (I# y) = x ==# y
++instance Eq Id where Id (I# x) == Id (I# y) = isTrue# (x ==# y)
+
+ instance Ord Id
+ where
+- Id (I# x) < Id (I# y) = x <# y
+- Id (I# x) <= Id (I# y) = x <=# y
++ Id (I# x) < Id (I# y) = isTrue# (x <# y)
++ Id (I# x) <= Id (I# y) = isTrue# (x <=# y)
+
+ compare (Id (I# x)) (Id (I# y)) =
+- if x ==# y then EQ else if x <# y then LT else GT
++ if isTrue# (x ==# y) then EQ else if isTrue# (x <# y) then LT else GT
+
+ instance Show Id
+ where
+diff --git a/uniqueid.cabal b/uniqueid.cabal
+index 8099520..83aaa39 100644
+--- a/uniqueid.cabal
++++ b/uniqueid.cabal
+@@ -18,7 +18,7 @@ Build-Type: Simple
+ Stability: experimental
+
+ Library
+- Build-Depends: base >= 3 && < 5
++ Build-Depends: base >= 3 && < 5, ghc-prim
+ Exposed-Modules: Data.Unique.Id
+ Extensions: MagicHash
+ Ghc-Options: -Wall
diff --git a/dev-haskell/uniqueid/metadata.xml b/dev-haskell/uniqueid/metadata.xml
new file mode 100644
index 00000000000..37fc7d42a40
--- /dev/null
+++ b/dev-haskell/uniqueid/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package provides splittable supplies of unique
+ identifiers. The implementation mimics (only) essential
+ parts of the code that is used internally in GHC for
+ the same purpose. After improvements of the value-supply
+ package it is now deprecated.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sebfisch/uniqueid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild b/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild
new file mode 100644
index 00000000000..f6011a70baa
--- /dev/null
+++ b/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Splittable Unique Identifier Supply"
+HOMEPAGE="http://github.com/sebfisch/uniqueid/wikis"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.8.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.8.patch
+}