summaryrefslogtreecommitdiff
path: root/dev-haskell/unixutils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/unixutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/unixutils')
-rw-r--r--dev-haskell/unixutils/Manifest1
-rw-r--r--dev-haskell/unixutils/metadata.xml12
-rw-r--r--dev-haskell/unixutils/unixutils-1.53.ebuild37
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/unixutils/Manifest b/dev-haskell/unixutils/Manifest
new file mode 100644
index 00000000000..10f31de37e7
--- /dev/null
+++ b/dev-haskell/unixutils/Manifest
@@ -0,0 +1 @@
+DIST Unixutils-1.53.tar.gz 12116 SHA256 995eff60414e4f5ed84c3ce4b78549fcf5d6e9bf613f400b5456b0996274083e SHA512 f3e2e1082d07d84a7c1918431146c607c62737320c744d2cd671a5fc55a02b6d189e4dc79c7451a8f5405369da78ceeaf046911b5a1f85b9b5205f5d618c9fc9 WHIRLPOOL a415ee054fe8fa57bd9e5b03468d8724ec055db133b73dc32c48c00fd068e02f10f5eb31495a68d4fb4d9cdcf8aec54bee5e82d0459baeead56a1f15c4197340
diff --git a/dev-haskell/unixutils/metadata.xml b/dev-haskell/unixutils/metadata.xml
new file mode 100644
index 00000000000..ea5bf928d68
--- /dev/null
+++ b/dev-haskell/unixutils/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A collection of useful and mildly useful functions that you might
+ expect to find in System.* which a heavy bias towards Unix-type operating systems.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">seereason/haskell-unixutils.git</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/unixutils/unixutils-1.53.ebuild b/dev-haskell/unixutils/unixutils-1.53.ebuild
new file mode 100644
index 00000000000..e261a9798b4
--- /dev/null
+++ b/dev-haskell/unixutils/unixutils-1.53.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Unixutils"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A crude interface between Haskell and Unix-like operating systems"
+HOMEPAGE="https://github.com/seereason/haskell-unixutils.git"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/exceptions:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/process-extras:=[profile?]
+ dev-haskell/puremd5:=[profile?]
+ dev-haskell/regex-tdfa:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ virtual/libc
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"