summaryrefslogtreecommitdiff
path: root/dev-haskell/uuid-types
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/uuid-types
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/uuid-types')
-rw-r--r--dev-haskell/uuid-types/Manifest2
-rw-r--r--dev-haskell/uuid-types/metadata.xml13
-rw-r--r--dev-haskell/uuid-types/uuid-types-1.0.0-r1.ebuild39
-rw-r--r--dev-haskell/uuid-types/uuid-types-1.0.1.ebuild34
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-haskell/uuid-types/Manifest b/dev-haskell/uuid-types/Manifest
new file mode 100644
index 00000000000..1dc867d29bc
--- /dev/null
+++ b/dev-haskell/uuid-types/Manifest
@@ -0,0 +1,2 @@
+DIST uuid-types-1.0.0.tar.gz 12649 SHA256 986eaf295f20853437448f18a38a0b05af547326190d9e1576459de656c3b225 SHA512 2d7d95188c1aeefd1d642d9c17a76f1fa3c9088723f360b9bafd6a46200823b0dc78a0d2b1c3feae276ac593c3cc4429ea7dd63ce560855b4be921edf3024f45 WHIRLPOOL e49d31f7649e5b035062ead307ffc62ac9ad813b7266e86a4cb1dbbbfd5b8aebb29b19c53ceb7e9d56ae9a1f5983e452e183a2b5c766d17c24cfd291840b5893
+DIST uuid-types-1.0.1.tar.gz 12018 SHA256 4b1e7f72892249195cb29a5b85b4e8ac75a5b278711a74b01eadde816dd03caf SHA512 284d20a684fa5d35de2e345712d48aea8b8ede2d1078ec871e6b1338fc0d619bf411b952aeefd5edb9866ef8db2626b00915cf4839440c4f5bff90255a16932c WHIRLPOOL 9ab5344a248ab6cd09c49a16cf2abd8b8b8c1c70c79f9c7c7b2517f64e1dc59fc0f83708c23ececf2ea855d5c137774f507f5484a9f1039f7eb9e169d8d43b98
diff --git a/dev-haskell/uuid-types/metadata.xml b/dev-haskell/uuid-types/metadata.xml
new file mode 100644
index 00000000000..8f68c3ec9fd
--- /dev/null
+++ b/dev-haskell/uuid-types/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library contains type definitions for Universally Unique Identifiers
+ and basic conversion functions.
+ See &lt;http://en.wikipedia.org/wiki/UUID&gt; for the general idea.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">aslatter/uuid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/uuid-types/uuid-types-1.0.0-r1.ebuild b/dev-haskell/uuid-types/uuid-types-1.0.0-r1.ebuild
new file mode 100644
index 00000000000..235de5a0083
--- /dev/null
+++ b/dev-haskell/uuid-types/uuid-types-1.0.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type definitions for Universally Unique Identifiers"
+HOMEPAGE="https://github.com/aslatter/uuid"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ || ( ( >=dev-haskell/hashable-1.1.1.0:=[profile?] <dev-haskell/hashable-1.2.0:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/quickcheck-2.4:2
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >=2.4 && < 2.8' 'QuickCheck >=2.4'
+}
diff --git a/dev-haskell/uuid-types/uuid-types-1.0.1.ebuild b/dev-haskell/uuid-types/uuid-types-1.0.1.ebuild
new file mode 100644
index 00000000000..cf23ac223c7
--- /dev/null
+++ b/dev-haskell/uuid-types/uuid-types-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type definitions for Universally Unique Identifiers"
+HOMEPAGE="https://github.com/aslatter/uuid"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ || ( ( >=dev-haskell/hashable-1.1.1.0:=[profile?] <dev-haskell/hashable-1.2.0:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.9
+ >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"